Bug 205818 - can't pvmove in rawhide
Summary: can't pvmove in rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
: 210754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-08 17:41 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 16:33:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2006-09-08 17:41:45 UTC
Description of problem:
Attempting to pvmove a filesystem from one raid-1 physical volume to another
will produce entries such as these in /var/log/messages (all prefixed by
device-mapper:)

unrecognised sync argument to mirror log: 2
dm-mirror: Error creating mirror dirty log
error adding target to table
unrecognised sync argument to mirror log: 2
dm-mirror: Error creating mirror dirty log
error adding target to table
device 253:4 too small for target
dm-linear: Device lookup failed
error adding target to table

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2630.fc6
lvm2-2.02.06-3
device-mapper-1.02.07-1.1

How reproducible:
Every time, but only tried on one box so far

Additional info:
It works on FC5 with the latest kernel update, but if I install the same kernel
on rawhide, it still doesn't work, so it looks like a userland problem.

Comment 2 Kenneth Topp 2006-10-24 04:57:45 UTC
Should we move this to fc6?  I must powercycle the box after attempting and then
run "mount -o remount,rw / && pvmove --abort" to clean up the mess.  I'm
guessing that this is fixed in the newer device mapper.   I'll build that myself
if it doesn't show up in rawhide when rawhide opens up again.

[root@static ~]# pvmove -v /dev/hda6
    Wiping cache of LVM-capable devices
    Finding volume group "tm"
    Archiving volume group "tm" metadata (seqno 22).
    Creating logical volume pvmove0
    Moving 44161 extents of logical volume tm/home
    Found volume group "tm"
    Updating volume group metadata
    Creating volume group backup "/etc/lvm/backup/tm" (seqno 23).
    Found volume group "tm"
    Found volume group "tm"
    Suspending tm-home (253:0)
    Found volume group "tm"
    Creating tm-pvmove0
    Loading tm-pvmove0 table
  device-mapper: reload ioctl failed: Invalid argument
  ABORTING: Temporary mirror activation failed.  Run pvmove --abort.
    Found volume group "tm"
    Loading tm-pvmove0 table
  device-mapper: reload ioctl failed: Invalid argument
    Loading tm-home table
  device-mapper: reload ioctl failed: Invalid argument
[root@static ~]# pvmove --abort^C^C [hangs at this point]

relevant messages:

Oct 24 00:13:55 static kernel: device-mapper: mirror log: unrecognised sync
argument to mirror log: 2
Oct 24 00:13:55 static kernel: device-mapper: table: 253:1: mirror: Error
creating mirror dirty log
Oct 24 00:13:55 static kernel: device-mapper: ioctl: error adding target to table
Oct 24 00:13:55 static kernel: device-mapper: mirror log: unrecognised sync
argument to mirror log: 2
Oct 24 00:13:55 static kernel: device-mapper: table: 253:1: mirror: Error
creating mirror dirty log
Oct 24 00:13:55 static kernel: device-mapper: ioctl: error adding target to table
Oct 24 00:13:55 static kernel: device-mapper: table: device 253:1 too small for
target
Oct 24 00:13:55 static kernel: device-mapper: table: 253:0: linear: dm-linear:
Device lookup failed
Oct 24 00:13:55 static kernel: device-mapper: ioctl: error adding target to table


Comment 3 Kenneth Topp 2006-10-27 15:03:08 UTC
With lvm2-2.02.12-2.fc7 and 
device-mapper-1.02.12-3.fc7, I get this now: 

# pvmove  -v /dev/hda6
    Wiping cache of LVM-capable devices
  Physical volume /dev/hda6 not found
  pvmove: Move extents from one physical volume to another

Comment 4 Alasdair Kergon 2006-10-27 15:35:40 UTC
comment 3 is a different problem that should be fixed by lvm2-2.02.13-1.fc7
which I submitted to the build system a few minutes ago

Comment 5 Kenneth Topp 2006-10-28 23:06:19 UTC
Now the pvmove works for me, but lvextend is broken.  Will look for another
bugzilla for that one, hopefully we won't push this lvm2 into fc6 until that's
fixed as well.

Comment 6 Kenneth Topp 2006-10-28 23:19:18 UTC
created bz#212774 for the lvextend issue.

Comment 7 Rahul Sundaram 2006-10-30 15:26:09 UTC
*** Bug 210754 has been marked as a duplicate of this bug. ***

Comment 8 Rahul Sundaram 2006-10-30 15:44:11 UTC
(In reply to comment #4)
> comment 3 is a different problem that should be fixed by lvm2-2.02.13-1.fc7
> which I submitted to the build system a few minutes ago

Can you get a update for FC6 too?

Comment 9 Andreas Øye 2006-11-18 10:30:28 UTC
FC6 needs this update as well, pvmove exhibits the same symptoms here.
kernel-2.6.18-1.2849.fc6
lvm2-2.02.06-4
device-mapper-1.02.07-3

Hangs and blocks all access to LV, until reboot with rescuecd to pvmove --abort
move. Seems other distros are affected as well. 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=383418
If this requires equivalent device-mapper and lvm2 the specfile should be fixed
to enforce that requirement. 

Comment 10 Ask Bjørn Hansen 2006-12-17 15:12:33 UTC
This is still happening,

  http://tmp.askask.com/2006/12/pvmove-failure.txt

[root@zaphod ~]# uname -a
Linux zaphod 2.6.18-1.2849.fc6xen #1 SMP Fri Nov 10 12:57:36 EST 2006 x86_64 x86_64 x86_64 GNU/
Linux
[root@zaphod ~]# lvm version
  LVM version:     2.02.06 (2006-05-12)
  Library version: 1.02.07 (2006-05-11)
  Driver version:  4.7.0

Comment 11 Ask Bjørn Hansen 2006-12-17 15:15:16 UTC
It seems like this is a bug with device-mapper needing to be updated:
   https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218169

Comment 12 Ask Bjørn Hansen 2006-12-18 09:41:14 UTC
FWIW, upgrading to the latest device-mapper fixed the problem for me, too.

Since LVM is used in the default install it's curious that Fedora would let this slip.  :-/


 - ask

Comment 13 Alasdair Kergon 2007-01-10 16:33:04 UTC
pushing the update out to fc5 and fc6


Note You need to log in before you can comment on or make changes to this bug.