Bug 205824 - rhn-setup should require libxml2-python
rhn-setup should require libxml2-python
Status: CLOSED DUPLICATE of bug 201877
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 14:34 EDT by Jay Lee
Modified: 2009-10-13 21:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 09:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Lee 2006-09-08 14:34:21 EDT
Description of problem:

Fresh install of rhel5 Server beta1.  Attempt to register system with RHN. 
rhn_register dies with:

Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 22, in ?
    from up2date_client import tui
  File "/usr/share/rhn/up2date_client/tui.py", line 20, in ?
    import rhnreg, hardware
  File "/usr/share/rhn/up2date_client/hardware.py", line 25, in ?
    import dbus
  File "/usr/lib64/python2.4/site-packages/dbus/__init__.py", line 1, in ?
    from _dbus import *
  File "/usr/lib64/python2.4/site-packages/dbus/_dbus.py", line 48, in ?
    from proxies import *
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 2, in ?
    import introspect_parser
  File "/usr/lib64/python2.4/site-packages/dbus/introspect_parser.py", line 1, in ?
    import libxml2
ImportError: No module named libxml2

Version-Release number of selected component (if applicable):

rhn-setup-0.1.3-1.el5
libxml2-python-2.6.26-2.1.1.x86_64.rpm

How reproducible:

Always

Steps to Reproduce:
1.  Fresh install
2.  Based on default options, libxml2-python was not installed, rhn-setup was
3.  rhn_register crashes
  
Actual results:

Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 22, in ?
    from up2date_client import tui
  File "/usr/share/rhn/up2date_client/tui.py", line 20, in ?
    import rhnreg, hardware
  File "/usr/share/rhn/up2date_client/hardware.py", line 25, in ?
    import dbus
  File "/usr/lib64/python2.4/site-packages/dbus/__init__.py", line 1, in ?
    from _dbus import *
  File "/usr/lib64/python2.4/site-packages/dbus/_dbus.py", line 48, in ?
    from proxies import *
  File "/usr/lib64/python2.4/site-packages/dbus/proxies.py", line 2, in ?
    import introspect_parser
  File "/usr/lib64/python2.4/site-packages/dbus/introspect_parser.py", line 1, in ?
    import libxml2
ImportError: No module named libxml2

Expected results:

rhn_register begins RHN registration process (text mode)

Additional info:

System was installed w/o X so this is all console based...
Comment 1 Jay Lee 2006-09-08 15:10:20 EDT
Not sure if I was clear enough in the original bug report but libxml2-python was
*not* installed originally.  I believe the rhn-setup RPM should have it as a
require since console based rhn_register will not work without it.

Jay
Comment 3 James Bowes 2006-09-21 09:10:43 EDT
rhn_register calls the dbus python bindings which in turn attempt to use
libxml2, so the missing requires is/was in dbus-python.

*** This bug has been marked as a duplicate of 201877 ***

Note You need to log in before you can comment on or make changes to this bug.