Bug 20584 - Problem on locking functions.
Problem on locking functions.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 10:08 EST by giuliano
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:28:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giuliano 2000-11-09 10:08:40 EST
I'm having some problem during compilation of some tarball external program
(ex. courier-imap).
When i try to create MakeFile with configure, the system give me an error
about locking functions on c++.
When i force the program to use fnctl or flock or lockf, another error say
me that fnctl is not working correctly.
The version on kernel is 2.2.16-3
Testing with 2.2.14-5.0 or 2.2.14-12 all works good.
Comment 1 giuliano 2000-11-16 03:20:30 EST
I don't know if this help, but i found some news.
I have installed a fresh 6.2 RH and upgraded to 2.2.14-22 kernel.
No problem on locking function.
Then i have upgraded to version 2.2.16-3.......
Now the system does not report any error on locking function!!!!
This is very strange, because upgrading directly from kernel 2.2.14-5.0 to
2.2.16-3 the problem appear.....

Note You need to log in before you can comment on or make changes to this bug.