Bug 205841 - SELinux breaks rpmdev-rpmdevelrpms script
SELinux breaks rpmdev-rpmdevelrpms script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 18:25 EDT by Dawid Gajownik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: selinux-policy-targeted-2.4.1-3.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 18:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Gajownik 2006-09-08 18:25:47 EDT
Description of problem:
SELinux breaks rpmdev-rpmdevelrpms script

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.7-2.fc5

Steps to Reproduce:
1. yum install rpmdevtools gettext
2. run rpmdev-rpmdevelrpms
  
Actual results:
[root@X ~]# rpmdev-rmdevelrpms
Found 1 devel packages:
  gettext-0.14.5-3
Remove them? [y/N] y
Removing......error: %preun(gettext-0.14.5-3.i386) scriptlet failed, exit status 255
Done.
[root@X ~]# rpm -q gettext
gettext-0.14.5-3
[root@X ~]# setenfoce 0
-bash: setenfoce: command not found
[root@X ~]# setenforce 0
[root@X ~]# rpmdev-rmdevelrpms
Found 1 devel packages:
  gettext-0.14.5-3
Remove them? [y/N] y
Removing........Done.
[root@X ~]#

Additional info:
AVC message:

Sep  9 00:17:58 X kernel: audit(1157753878.578:7): avc:  denied  { transition }
for  pid=15513 comm="rpmdev-rm
develr" name="bash" dev=hda5 ino=388624 scontext=user_u:system_r:unconfined_t:s0
tcontext=user_u:system_r:rpm_
script_t:s0 tclass=process
Comment 1 Daniel Walsh 2006-09-18 13:51:05 EDT
Fixed in selinux-policy-2.3.14-4
Comment 2 Dawid Gajownik 2006-10-27 18:48:38 EDT
Seems to be fixed in FC6 (selinux-policy-targeted-2.4.1-3.fc6). Thanks!

Note You need to log in before you can comment on or make changes to this bug.