Bug 205881 - sane-backends-1.0.18-2.fc5 conflicts with sane-backends-1.0.17-5.fc5.9
sane-backends-1.0.18-2.fc5 conflicts with sane-backends-1.0.17-5.fc5.9
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: Reopened
: 207268 207465 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 10:11 EDT by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 09:43:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2006-09-09 10:11:50 EDT
Description of problem:
Upgrading from sane-backends-1.0.17-5.fc5.9 
to sane-backends-1.0.18-2.fc5,
currently in fc5 updates-testing, fails.

Version-Release number of selected component (if applicable):
sane-backends-1.0.17-5.fc5.9
sane-backends-1.0.18-2.fc5

How reproducible:
always

Steps to Reproduce:
1. yum -y --enablerepo=updates-testing update sane-backends
  
Actual results:
 file /etc/sane.d/avision.conf from install of sane-backends-1.0.18-2.fc5
conflicts with file from package sane-backends-1.0.17-5.fc5.9
...


Expected results:
yum update succeeding.

Additional info:
Uneducated guess, this is caused by the change in the %dist tag.
Comment 1 Nils Philippsen 2006-09-11 09:12:33 EDT
On what architecture do you see this problem? This very much sounds like trying
to update only one architecture of the package on a multilib system (e.g. x86_64).
Comment 2 Scott Tsai 2006-09-11 09:18:25 EDT
I'm on x86_64.
Indeed after checking my yum logs I see that I had the sane-backends.i386
package installed but only updated from the x86_64 repo.
I'm closing this bug, thanks for your time.
Comment 3 Nils Philippsen 2006-09-20 10:38:04 EDT
*** Bug 207268 has been marked as a duplicate of this bug. ***
Comment 4 Nils Philippsen 2006-09-22 05:07:06 EDT
*** Bug 207465 has been marked as a duplicate of this bug. ***
Comment 5 Nils Philippsen 2006-09-22 05:13:41 EDT
This actually is a bug, not in the package itself but in the repository.

With the update to sane-backends-1.0.18, the libraries were split off into the
-libs subpackage to avoid multilib issues. Now something went wrong with how the
FC5 update packages were pushed into the repository: The x86_64 repository now
contains i386 and x86_64 packages of sane-backends, but only an x86_64 package
of sane-backends-libs while it should contain only the x86_64 package of
sane-backends and both i386 and x86_64 packages of sane-backends-libs.

I'll contact release-engineering to get this resolved.
Comment 6 Nils Philippsen 2007-02-08 09:43:03 EST
I just checked that the repository contains both i386 and x86_64 versions of
sane-backends-libs. Closing.

Note You need to log in before you can comment on or make changes to this bug.