Bug 205890 - Installing/upgrading a package locally fails using pirut
Installing/upgrading a package locally fails using pirut
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 205895 206038 206338 206603 206799 207830 211750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 12:50 EDT by Deji Akingunola
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 15:47:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deji Akingunola 2006-09-09 12:50:58 EDT
Description of problem:
Installing/upgrading a local package by selecting 'Sofware Instaler' after
right-clicking on the package in nautilus causes a traceback below.

Version-Release number of selected component (if applicable):pirut-1.1.12-1


How reproducible: always


Steps to Reproduce:
1. Download a new package
2. browse to the download location on nautilus 
3. Right-click on the package and select 'software installer'
  
Actual results: Opens up as if its going to work, but produces a traceback;
<<

Component: Software Installer
Summary: TB31e7d981 system-install-packages:109:populatePackages:AttributeError:
'SinglePackageInstaller' object has no attribute 'read_ts'

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 244, in ?
    main()
  File "/usr/sbin/system-install-packages", line 240, in main
    pkginst.run()
  File "/usr/sbin/system-install-packages", line 230, in run
    self.doRefresh()
  File "/usr/sbin/system-install-packages", line 90, in doRefresh
    self.populatePackages()
  File "/usr/sbin/system-install-packages", line 109, in populatePackages
    po = YumLocalPackage(ts=self.read_ts, filename=pkg)
AttributeError: 'SinglePackageInstaller' object has no attribute 'read_ts'

Local variables in innermost frame:
installs: []
self: <__main__.SinglePackageInstaller object at 0xc705d0>
updates: []
pkg: /home/deji/Desktop/fedora-logos-1.1.53-2.fc6.noarch.rpm
>>

Expected results: 


Additional info: This surely does use to work at least on FC5.
Comment 1 Jeremy Katz 2006-09-11 15:47:17 EDT
Fixed in CVS
Comment 2 Jeremy Katz 2006-09-11 15:47:32 EDT
*** Bug 205895 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2006-09-11 15:54:45 EDT
*** Bug 206038 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2006-09-13 17:07:25 EDT
*** Bug 206338 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-09-15 05:58:08 EDT
*** Bug 206603 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2006-09-18 13:01:19 EDT
*** Bug 206799 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-09-25 09:34:11 EDT
*** Bug 207830 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2006-10-21 16:45:16 EDT
*** Bug 211750 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.