Bug 205898 - VIA VT8237A SATA support
VIA VT8237A SATA support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://marc.theaimsgroup.com/?l=linux...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 15:19 EDT by Yasuma Takeda
Modified: 2015-01-04 17:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-23 22:32:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yasuma Takeda 2006-09-09 15:19:58 EDT
Description of problem:
The kernel-2.6.17-1.2517.fc6 doesn't support VIA VT8237A SATA controller.
The patch was sent to LKML.
http://marc.theaimsgroup.com/?l=linux-ide&m=115552504713314&w=2

I confirmed that patch was needed for the VIA VT8237A SATA controller.

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2517.fc6

How reproducible:
Install Fedora Core 6 test2(i386) to the machine.
My machine uses ASUS P5VD2-MX mother board. It uses VIA VT8237A SATA 
controller.
So, I can't install the FC6 test2.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
The installer can't find the HDD which is connected by SATA.

Expected results:
I can install the Fedora Core 6 to the machine.

Additional info:
Comment 1 Dave Jones 2006-09-11 03:06:29 EDT
I merged this into cvs yesterday. It'll be in rawhide soon.
(It's frozen right now due to the FC6test3 freeze).
Comment 2 Steve 2006-09-20 23:39:52 EDT
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=28a2a3f58707cba16b329b90f601c01599456491
fixed in 2.6.18-rc7 (and in new 2.6.18)

will 2.6.18 upstream (or later) kernel make it in FC6 final?
Comment 3 Dave Jones 2006-09-23 22:32:09 EDT
yes

Note You need to log in before you can comment on or make changes to this bug.