Bug 205926 - knetworkmanager doesn't tell NM about known non-broadcast ESSID networks at first startup
knetworkmanager doesn't tell NM about known non-broadcast ESSID networks at f...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On: 208651
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 07:01 EDT by Stefan Becker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-28 19:44:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 133900 None None None Never

  None (edit)
Description Stefan Becker 2006-09-10 07:01:10 EDT
Description of problem:

I'm using a PCMCIA WLAN card. If the card is not present when knetworkmanager
starts up the first time after a boot it doesn't tell the NetworkManager to look
out for networks with non-broadcast ESSID.

Version-Release number of selected component (if applicable):

knetworkmanager-0.1-0.3.svn20060625.fc5
NetworkManager-0.6.4-1.fc5
NetworkManager-gnome-0.6.4-1.fc5
NetworkManager-glib-0.6.4-1.fc5
dbus-qt-0.61-4.fc5
kmod-madwifi-0.9.2-2.2.6.17_1.2174_FC5
madwifi-0.9.2-1.lvn5

NOTE: I had to patch the /usr/sbin/NetworkManager binary so that it doesn't
request the madwifi driver, otherwise NM doesn't work with the latest madwifi
driver anymore. See also bug #195411.

How reproducible: Always

Steps to Reproduce:
1. Setup an association to a network with non-broadcast ESSID (ie. a hidden
cell) in knetworkmanager
2. Remove the PCMCIA WLAN card and reboot the machine
3. After KDE session has started knetworkmanager insert the PCMCIA WLAN card again

Actual results:
Only networks with broadcast ESSID show up in the wireless networks list.

Expected results:
Also non-broadcast ESSID networks known to knetworkmanager should show up in the
list.

Additional info:
Once you restart knetworkmanager or NetworkManager the non-broadcast ESSID
networks show up in the list. If you insert the PCMCIA WLAN card after boot but
before you login to KDE it also works OK.
Comment 1 Stefan Becker 2006-09-11 05:53:13 EDT
Added KDE bug tracking system ID
Comment 2 Dennis Gilmore 2006-11-14 22:23:50 EST
can you see if this is fixed in the latest build please? 
Comment 3 Stefan Becker 2006-11-17 13:09:52 EST
Because of bug #208651 my PCMCIA WLAN card is no longer used by NetworkManager
and therefore I'm currently unable to re-test this bug.
Comment 4 Stefan Becker 2006-11-17 13:25:22 EST
If I use "service NetworkManager restart" the card gets recognized and
non-broadcast ESSID networks are shown. So it could be that the bug is fixed.

I'll only close this after automatic recognition of the PCMCIA WLAN card has
been fixed, ie. I can re-test this without restarting NetworkManager.
Comment 5 Stefan Becker 2007-04-28 19:44:04 EDT
Retested with F7test4. Works fine now:

NetworkManager-0.6.5-1.fc7
knetworkmanager-0.1-0.9.svn20070409.fc7

Note You need to log in before you can comment on or make changes to this bug.