Bug 205933 - The current rebuild-sdk-features script is not working for Eclipse 3.2
The current rebuild-sdk-features script is not working for Eclipse 3.2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 10:44 EDT by Henning Schmiedehausen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.2.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 13:58:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
An updated rebuild-sdk-features script which fixes these problems. (3.81 KB, application/octet-stream)
2006-09-10 10:44 EDT, Henning Schmiedehausen
no flags Details
An updated rebuild-sdk-features script which fixes these problems. (3.81 KB, text/plain)
2006-09-11 11:56 EDT, Henning Schmiedehausen
no flags Details

  None (edit)
Description Henning Schmiedehausen 2006-09-10 10:44:35 EDT
Description of problem:

The rebuild-sdk-features script seems to be still on 3.1 level. It also does 
not take into account that org.eclipse.sdk feature and plugin have different
versions

Version-Release number of selected component (if applicable):
3.2.0-4.fc6

How reproducible:
Always


Steps to Reproduce:
1. Install the RPM. Run /usr/share/eclipse/buildscripts/rebuild-sdk-features
2. Load /usr/share/eclipse/features/org.eclipse.sdk_<version>/features.xml in
   an editor.
3. Look for the "plugin" line that references the sdk plugin. It has the
   wrong version. 
4. Look for the <url> locations of the update sites. They still reference 3.1
  
Actual results:

Eclipse shows a red x for the Eclipse Project SDK for /usr/share/eclipse
under Help -> Software Updates -> Manage Configuration because of this. Also
the update manager does not work correctly.

Expected results:
There should be no errors in the Manager Configuration window. Update manager
should work.

Additional info:

I've attached a fixed rebuild-sdk-configuration script which amends these
problems.
Comment 1 Henning Schmiedehausen 2006-09-10 10:44:35 EDT
Created attachment 135929 [details]
An updated rebuild-sdk-features script which fixes these problems.
Comment 2 Henning Schmiedehausen 2006-09-11 11:56:19 EDT
Created attachment 136010 [details]
An updated rebuild-sdk-features script which fixes these problems.

A minor typo which rendered the platform.xml as illegal XML.
Comment 3 Ben Konrath 2006-09-20 17:57:09 EDT
Thanks for all your work here. I think I found a way to get rid of
rebuild-sdk-features so we don't run into these problems again. Can you test out
3.2.0-6.fc6 and let me know if the problem is fixed? Thanks again.
Comment 4 Ben Konrath 2006-10-04 13:58:22 EDT
This is fixed with the latest package, closing bug. Thanks again for your help here.

Note You need to log in before you can comment on or make changes to this bug.