Bug 205939 - popt cvs and 1.10.4 install libs to lib6464
popt cvs and 1.10.4 install libs to lib6464
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 11:53 EDT by Jory A. Pratt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 14:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
configure.ac patch to fix /usr/lib6464 bug (441 bytes, text/x-patch)
2006-09-10 11:53 EDT, Jory A. Pratt
no flags Details
popt-1.10.4-lib64.patch (522 bytes, patch)
2006-09-10 13:18 EDT, Patrick McLean
no flags Details | Diff

  None (edit)
Description Jory A. Pratt 2006-09-10 11:53:29 EDT
Install of libs to wrong directory on 64bit archs.
Comment 1 Jory A. Pratt 2006-09-10 11:53:32 EDT
Created attachment 135932 [details]
configure.ac patch to fix /usr/lib6464 bug
Comment 2 Michael Jennings (KainX) 2006-09-10 12:30:04 EDT
Patches should be in unified diff format (diff -u), and the latest popt is
1.10.7, not 1.10.4.

Also, this patch doesn't look portable to non-bash versions of /bin/sh.
Comment 3 Patrick McLean 2006-09-10 13:18:49 EDT
Created attachment 135934 [details]
popt-1.10.4-lib64.patch

new configure.ac patch that should work on a non-bash sh
Comment 4 Jeff Johnson 2007-01-18 00:23:57 EST
FIxed in rpm cvs, will be in popt-1.10.8-0.11 when built.

UPSTREAM
Comment 5 Panu Matilainen 2007-08-09 14:15:20 EDT
popt-1.10.4 never was in Fedora AFAICT, at least the current version doesn't
suffer from this and a newer popt is on its way in anyway, see bug 249352.
UPSTREAM / RAWHIDE / WHATEVER

Note You need to log in before you can comment on or make changes to this bug.