Bug 205948 - lspci: pci_lookup_name: buffer too small
lspci: pci_lookup_name: buffer too small
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pciutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 14:15 EDT by Milan Kerslager
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: pciutils-2.2.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 08:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2006-09-10 14:15:19 EDT
On Foxconn Intel 915P7AD motherboard:

# lspci
[...]
01:05.0 Mass storage controller: <pci_lookup_name: buffer too small> (rev 13)
[...]

# lspci -n | grep 01:05.0
01:05.0 0180: 1283:8212 (rev 13)
Comment 1 Harald Hoyer 2006-09-25 09:43:58 EDT
seems like they hardcoded the name length to 128 in pciutils and 1283:8212 in
/usr/share/hwdata/pci.ids is:
1283  Integrated Technology Express, Inc.
        8212  IT/ITE8212 Dual channel ATA RAID controller (PCI version seems to
be IT8212, embedded seems to be ITE8212)

which is too long... I will eventually raise the name length

Note You need to log in before you can comment on or make changes to this bug.