Bug 20596 - KickStart CD installation which worked on 6.2 fails on 7.0
KickStart CD installation which worked on 6.2 fails on 7.0
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-11-09 11:57 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-04 10:44:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-09 11:57:06 EST
KickStart installation worked on 6.2 in the following scenario.

1. ks.cfg put on RedHat CD1 into /images
2. /images/boot.img has been edited and file syslinux.cfg 
   contained additional entry like this:
   default quick
   prompt 10
   label quick  
       kernel vmlinuz  
       append ks=cdrom:/images/ks.cfg initrd=initrd.img local text
And this worked.

The same ks.cfg was tested on RedHat 7.0 and worked fine from floppy.

Now if we put ks.cfg on RedHat 7.0 CD1 into /images
and we are trying to boot from CD using 'quick'
KickStart is not being executed.

We tryied as well to boot from this CD and specify 

vmlinuz ks=hda:/images/ks.cfg initrd=initrd.img text

This gives us a message

running anaconda may take some time...

and after that instead of executing kickstart it asks for
language (as with usual text mode installation).

We tryed many combinations

vmlinuz ks=cdrom:/images/ks.cfg initrd=initrd.img text
vmlinuz ks=hda:/images/ks.cfg initrd=initrd.img text
vmlinuz ks=file:/mnt/source/images/ks.cfg initrd=initrd.img text

and coudn't make it work.
It seems anaconda is broken in 7.0 and doesn't allow us to refer
to ks.cfg on cdrom in syslinux.cfg in boot.img

This used to work fine in 6.2

Mikhail Grushinskiy
Comment 1 Michael Fulbright 2000-11-09 16:30:54 EST
Passed to QA to reproduce.
Comment 2 Brock Organ 2000-11-14 14:28:31 EST
could you attach the kickstart file you were able to use in 6.2 (but failed with
7) ...?
Comment 3 Michael Fulbright 2000-12-04 10:44:44 EST
Please reopen this report if you continue to have problems.
Comment 4 stephenh 2000-12-11 01:28:12 EST
I am having a similar problem. I am trying to run a kickstart installation
entirely off a CD with no floppy involved. Do do this I burnt a new CD with
ks.cfg in the top level directory of the CD, I modified the syslinux.cfg file to
the following:

default ks 
prompt 0 
label ks
  kernel vmlinuz
  append ks=cdrom:/ks.cfg initrd=initrd.img 

I've updated /images/boot.img with this version of syslinux.cfg.

When I do an install a get the "Choose a Language" screen, thus kickstart is not

Interestingly if I continue with the manual install when I get to the
"Installation Method" screen I select "Local CDROM". When doing this I get an
"Error" screen which reads like "I could not find a Red Hat Linux CDROM in any
of your CDROM drives. Please insert the Red Hat CD and press "OK" to retry".
Clearly there is something amiss here, because there is a Red Hat CD in one of
my CDROM drive, except some minor changes. After pressing retry many times I
notice the following messages on the log screen (ALT-F3):

* trying to mount device hdc
* trying to mount device hdc

It looks from this that ananconda is unable to mount my CD. I'm guessing that
this is because it is already mounted. Furthermore, I'm thinking that kickstart
is not working because it can't mount my CDROM drive.

I have tested the ks.cfg on a floppy when booting from a floppy and its works.

Stephen H.

Note You need to log in before you can comment on or make changes to this bug.