Bug 205965 - pcreapi(3) man page references the wrong include file
pcreapi(3) man page references the wrong include file
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pcre (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 19:48 EDT by Landon Curt Noll
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 10:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Landon Curt Noll 2006-09-10 19:48:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.5) Gecko/20060726 Red Hat/1.5.0.5-0.el4.1 Firefox/1.5.0.5 pango-text

Description of problem:
The pcreapi(3) man page references:

#include <pcre.h>

at the top of the man page.  It should reference:

#include <pcre/pcre.h>

instead.

Version-Release number of selected component (if applicable):
pcre-devel-4.5-3.2.RHEL4

How reproducible:
Always


Steps to Reproduce:
1.man 3 pcreapi
2.ls /usr/include/pcre.h
3.

Actual Results:
The ls /usr/include/pcre.h file is not found.

Expected Results:
The pcreapi(3) man page should reference <pcre/pcre.h> because /usr/include/pcre/pcre.h exists, not /usr/include/pcre.h.

Additional info:
Comment 1 Ngo Than 2007-10-18 10:38:33 EDT
it's already fixed in RHEL-5 release.

Note You need to log in before you can comment on or make changes to this bug.