Bug 206032 - xen kernel hangs after starting X
xen kernel hangs after starting X
Status: CLOSED DUPLICATE of bug 207432
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On: 217715
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 12:21 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 11:54:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-11 12:21:26 EDT
Description of problem:

After X is started, the Xen kernel will hang on this box.

[root@apone ~]# lspci
00:00.0 Host bridge: Intel Corporation Unknown device 2980
00:01.0 PCI bridge: Intel Corporation Unknown device 2981
00:02.0 VGA compatible controller: Intel Corporation Unknown device 2982
00:19.0 Ethernet controller: Intel Corporation 82566DC Gigabit Network Connection
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #4
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #5
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #2
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #1
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #2
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI #3
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f0)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller

X stays running long enough for gdm to start, but soon after the machine hard locks.

Version-Release number of selected component (if applicable):

kernel-xen-2.6.17-1.2636.fc6
xorg-x11-server-Xorg-1.1.1-34.fc6
xorg-x11-drv-i810-1.6.5-5.fc6

How reproducible:

Every time.
Comment 1 Mohammed Ghanawi 2006-10-10 15:19:58 EDT
This locking happens with the ATI driver too, and FC6 test3. Xorg starts to
consume 100% CPU utilization making the system totaly useless, unless with a
hard reset. The same does not happen when using a normal kernel.
Comment 2 Stephen Tweedie 2006-11-27 10:08:25 EST
re comment #1:  the bug report here was originally for

00:02.0 VGA compatible controller: Intel Corporation Unknown device 2982

which is an Intel graphics controller.  Please open a separate bug report if you
have an ATI problem.
Comment 3 Stephen Tweedie 2006-11-27 10:09:37 EST
Can you hook up a serial console and see if you're getting panics from the
kernel when this happens?

Also, what exact graphics chipset is this?

 Thanks.

Comment 4 Bill Nottingham 2006-11-27 13:09:38 EST
This (was, don't have it up ATM) an i965 box, and this is almost certainly a dup
of 214635 and associated issues.
Comment 5 Bill Nottingham 2006-11-30 11:54:11 EST

*** This bug has been marked as a duplicate of 207432 ***

Note You need to log in before you can comment on or make changes to this bug.