Bug 206050 - excessive cpu usage, apparent hang
Summary: excessive cpu usage, apparent hang
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-11 18:16 UTC by John Dennis
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 20:57:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Dennis 2006-09-11 18:16:00 UTC
I just discovered this. If the server catches an exception when handing a client
request the socket will be closed but the client in various places is looking
for socket exceptions and not a null return from socket.recv, in addition the
client code is not correct with respect to gobject.IO_HUP, it needs to
immediately remove the io watcher and only then queue a future reconnect
request. The problem is the io watch routine will keep firing signaling an
IO_HUP if it has not been removed from the watch queue.

Comment 1 John Dennis 2006-09-29 20:57:01 UTC
The code in question was totally re-written, no evidence of this behavior anymore.


Note You need to log in before you can comment on or make changes to this bug.