Bug 206097 - bind-config needs rebuild for bind-9.3.2-33.fc5 update
bind-config needs rebuild for bind-9.3.2-33.fc5 update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 21:57 EDT by Matthew Saltzman
Modified: 2013-01-09 23:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 04:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2006-09-11 21:57:59 EDT
Description of problem:
After updating bind to bind-9.3.2-33.fc5, yum wants to update bind-config (even
though I didn't have it installed), but bind-config is still at 9.3.2-20.FC5.

Version-Release number of selected component (if applicable):
bind-config-9.3.2-20.FC5

How reproducible:
Always

Steps to Reproduce:
1. yum update to get current bind
2. yum updagte again
3.
  
Actual results:
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for bind-config to pack into transaction set.
bind-config-9.3.2-20.FC5. 100% |=========================|  35 kB    00:00
---> Package bind-config.i386 30:9.3.2-20.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-20.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-20.FC5 is needed by package bind-config

Expected results:
Either no update (I didn't have bind-config installed before) or a successful
update.

Additional info:
Comment 1 Martin Stransky 2006-09-12 03:25:01 EDT
You need to install caching-nameserver package....
Comment 2 James 2006-09-12 07:31:30 EDT
Having caching-namserver doesn't seem to make a difference:

[root@localhost Mike]# rpm -q caching-nameserver
caching-nameserver-9.3.2-33.fc5
[root@localhost Mike]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/4]
core                                                                 [2/4]
updates                                                              [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package bind-config.i386 30:9.3.2-20.FC5 set to be updated
--> Running transaction check
--> Processing Dependency: bind = 30:9.3.2-20.FC5 for package: bind-config
--> Finished Dependency Resolution
Error: Missing Dependency: bind = 30:9.3.2-20.FC5 is needed by package bind-config
Comment 3 Matthew Saltzman 2006-09-12 07:44:47 EDT
I already *had* caching-nameserver installed, and it was updated along with bind.

$ rpm -q caching-nameserver
caching-nameserver-9.3.2-33.fc5

What does caching-nameserver have to do with bind-config?
Comment 4 Matthias Saou 2006-09-12 08:04:03 EDT
Well, same problem here. Steps to reproduce :
- Install a new FC5 system
- Run "yum update".... *boom*

The problem here is that the initial system has caching-nameserver, which
bind-config-9.3.2-20.FC5.i386.rpm obsoletes :

$ rpm -qp --obsoletes bind-config-9.3.2-20.FC5.i386.rpm 
caching-nameserver  

But this bind-config package requires an exact version of bind which is
available, but since there is also a newer one, yum doesn't list it :

$ rpm -qp --requires bind-config-9.3.2-20.FC5.i386.rpm 
bind = 30:9.3.2-20.FC5
[...]

Installed Packages
bind.i386                                30:9.3.2-4.1           installed
bind-libs.i386                           30:9.3.2-4.1           installed
bind-utils.i386                          30:9.3.2-4.1           installed
Available Packages
bind.i386                                30:9.3.2-33.fc5        updates
bind-chroot.i386                         30:9.3.2-33.fc5        updates
bind-config.i386                         30:9.3.2-20.FC5        updates <- old
bind-devel.i386                          30:9.3.2-33.fc5        updates
bind-libbind-devel.i386                  30:9.3.2-33.fc5        updates
bind-libs.i386                           30:9.3.2-33.fc5        updates
bind-sdb.i386                            30:9.3.2-33.fc5        updates
bind-utils.i386                          30:9.3.2-33.fc5        updates

So... why is bind-config still at 30:9.3.2-20.FC5 instead of 30:9.3.2-33.fc5?
Comment 5 Martin Stransky 2006-09-12 08:13:48 EDT
Jess, 

can we remove the bind-config 30:9.3.2-20.FC5 package from updates?
Comment 6 Matthias Saou 2006-09-12 08:15:44 EDT
Oh no! caching-nameserver 30:9.3.2-33.fc5 requires "bind = 30:9.3.2-33.fc5"...
but the old bind-config obsoletes it!

Please have the older bind-config removed from the FC5 updates directory, it
should "fix" the problem.

*BUT*

The real issue here is that this bind-config has obsoleted "caching-nameserver"
without any version. If it was made to obsolete only caching-nameserver up to a
certain version, lower than the new re-introduced caching-nameserver, then this
problem wouldn't have existed.

Please try to ALWAYS use a version for the obsoletes tag. Doing otherwise nearly
always asking for trouble.
Comment 7 Kazutoshi Morioka 2006-09-12 13:44:23 EDT
Please remove bind-config-9.3.2-22.fc5 from updates-testing repository.
Comment 8 Jesse Keating 2006-09-12 13:50:49 EDT
bind-config was removed from the updates directory, I missed the
updates-testing, will remove it there too.
Comment 9 Jesse Keating 2006-09-12 14:04:09 EDT
And removed from updates-testing.
Comment 10 Martin Stransky 2006-09-13 04:53:02 EDT
(In reply to comment #9)
> And removed from updates-testing.

Thanks!
Comment 11 Kostas 2006-09-13 19:31:48 EDT
I still have the bind depedency problem. 
What should I do?
Comment 12 Peter Fales 2006-09-13 21:34:55 EDT
Still seeing the problem here too.   I've got a clean FC5 system which has been
running "yum update" every few days and it's been working fine.  Today I started
seeing this "bind-config" error.   It's not clear to me what the problem is or
how to work around it.
Comment 13 Jacek Piskozub 2006-09-14 01:49:17 EDT
You can have two kinds of problems:

1) Your yum randomly hits mirror sites which still have
bind-config-9.3.2-20.FC5.i386.rpm. In this case, sooner or later the problem
will solve itself. Ypu may help it changing the metadata_expire value to for
example 5 (seconds) and try "yum update" for example five times (then restore
the original value, if you want).

2) If that does not help, you may have the rpm database slightly screwed up. I
believe I had this on one of my servers. The following procedure apparently has
solved it. Do a "rpm --rebuilddb". Have patience to let it run (or try "rpm -vv
--rebuilddb" if you like lotsa messages on your screen). Not to make the
situation even worse, you should first backup the rpm database, namely all the
files in /var/lib/rpm catalog. A good page on this operation can be found here:
http://www.rpm.org/hintskinks/repairdb/

I hope that helps.
Comment 14 Jacek Piskozub 2006-09-14 01:52:15 EDT
Errata: "metadata_expire" is controlled from the /etc/yum.conf file.
Comment 15 Matthias Saou 2006-09-14 04:52:37 EDT
One can also try "yum clean all" to remove all headers, metadata and packages.
Otherwise, if the package is still "seen", then "yum update
--exclude=bind-config" should work as a temporary workaround.
Comment 16 Peter Fales 2006-09-15 17:35:28 EDT
For the record, it was pilot error in my case.   Our internal mirror was out of
space and only partially updated.  After I pointed my configuration to the
current  public mirror, it worked as expected.

Note You need to log in before you can comment on or make changes to this bug.