Bug 206146 - multiple lines printed during GRUB countdown
multiple lines printed during GRUB countdown
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: grub (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Václav Pavlín
: Reopened
: 210298 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 10:36 EDT by Aleksandar Milivojevic
Modified: 2013-01-14 04:55 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 04:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-09-12 10:36:29 EDT
Description of problem:
Just an cosmetic thing.

When using hiddenmenu, Grub prints multiple lines during countdown:

Booting ... in 5 seconds
Booting ... in 4 seconds
Booting ... in 3 seconds
and so on

The old (correct?) behaviour was to keep this on single line.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Use hiddenmenu option in grub.conf (default)
2.
3.
  
Actual results:
Always

Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2006-10-26 16:15:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jeremy Katz 2006-11-30 11:22:59 EST
This doesn't happen for me... are you using a normal console?
Comment 4 Jeremy Katz 2006-11-30 11:45:08 EST
*** Bug 210298 has been marked as a duplicate of this bug. ***
Comment 5 Aleksandar Milivojevic 2006-11-30 16:45:03 EST
Hi Jeremy,

The installation was on VmWare ESX 3.0.  The console was normal as ESX console
could be normal ;-)

Anyhow, I retested with RHEL5 beta 2 (on both real hardware and on ESX 3.0
virtual machine) and it seems that the issue is resolved.  It counts on a single
line as it was supposed to do.  I guess the problem was something with the page
layout (which changed between beta1 and beta2)?
Comment 6 Daniel Riek 2007-01-03 21:28:42 EST
Closing CURRENTRELEASE based on comment #5
Comment 7 Bryan Yount 2012-05-02 11:15:49 EDT
Reopening this bug and changing the title to match the problem better. I have described this issue in bugzilla #617155 for RHEL 6 but I've been able to reproduce the same issue in RHEL 5. Here is the same text I posted in the other bug:

The problem occurs here whenever you have a grub title entry that is longer than the amount of text that can fit on a single line.

So, while this fits on a single line:
title Red Hat Enterprise Linux Server (2.6.18-164.el5)

This, does not:
title Red Hat Enterprise Linux Server (2.6.18-164.15.1.el5.i686)

Whenever you have this much text, the line word-wraps and causes the next line
to be drawn below the original line instead of overwriting it. This causes the
following behavior:

Booting Red Hat Enterprise Linux Server (<kernel_version>) in 5...
Booting Red Hat Enterprise Linux Server (<kernel_version>) in 4...
Booting Red Hat Enterprise Linux Server (<kernel_version>) in 3...
Booting Red Hat Enterprise Linux Server (<kernel_version>) in 2...
Booting Red Hat Enterprise Linux Server (<kernel_version>) in 1...
Comment 8 Václav Pavlín 2013-01-14 04:55:49 EST
Hi Bryan,

The cause of the problem is the same as in bug you mentioned - too long string provided to grub by other component.

So I think the result is the same - CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.