Bug 206161 - Many dependency warning issued after selecting s/w for installation
Many dependency warning issued after selecting s/w for installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dennis Gregorovic
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 11:52 EDT by Jeff Burrell
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/anaconda.log file from test machine (207.85 KB, application/octet-stream)
2006-09-12 14:45 EDT, Jeff Burrell
no flags Details

  None (edit)
Description Jeff Burrell 2006-09-12 11:52:42 EDT
Description of problem:
In installing the desktop client version for x86-64, I selected every option for
additional software, except web server. When I look at the screen contents on VT
#3(ctrl-alt-F3), I see lots and lots of warnings about dependency for a lot of
different rpms.

It also takes more than a minute before the "next" key is enabled.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Use x86-64 client install DVD
2. Install using "D" for Desktop client
3. Select first two categories of software(window manager & development?), but
don't select "web server"
4. Select every optional component under both selected categories
5. Select "next"
6. ctrl-alt-F3 to view VT3's contents
  
Actual results: many, many dependancy warnings


Expected results: No dependency warnings


Additional info:
Comment 1 Jeff Burrell 2006-09-12 12:48:26 EDT
Here are a couple of additions/corrections to "Steps to Reproduce":

In step #3, I selected the categories "Office & Productivity" & "Software
Development".

After #3, I selected "customize now" and proceeded to select all of the
components(step #4) listed for each of the first 5
options(Desktop/Applications/Development/Servers/BaseSystem) but added nothing
in "Languages".
Comment 2 Chris Lumens 2006-09-12 14:06:53 EDT
Please post an example of the sorts of messages you are seeing, as there are a
variety of dependancy messages that can appear in the logs.
Comment 3 Jeff Burrell 2006-09-12 14:28:52 EDT
Unless there's a log somewhere which captures messages posted prior to 
installation, which I doubt there is, there's no good way to capture messages 
like this other than to manual copy them down. 
Comment 4 Jeremy Katz 2006-09-12 14:32:07 EDT
There's /tmp/anaconda.log at install-time which gets copied to
/var/log/anaconda.log on the installed system.
Comment 5 Jeff Burrell 2006-09-12 14:45:20 EDT
Created attachment 136098 [details]
/var/log/anaconda.log file from test machine
Comment 6 Jeremy Katz 2006-09-12 14:51:23 EDT
Packages that are dep required are only present in the Workstation variant.
Comment 8 Jay Turner 2006-09-20 15:03:22 EDT
Need to have clean rpm verifies (i.e. no missing deps)  QE ack for B2.  See
section 9c of the release criteria.
Comment 12 RHEL Product and Program Management 2006-12-22 19:12:56 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.