Bug 206164 - Closing Eclipse loses defined symbols/include path for Autotool project headers
Closing Eclipse loses defined symbols/include path for Autotool project headers
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnston
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 12:00 EDT by Jeff Johnston
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 16:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnston 2006-09-12 12:00:54 EDT
If a C/C++ source file of an Autotools project is opened in the editor window
and a header file is subsequently opened by double-clicking in the Outline view,
defined symbol and inclue path information is taken from the actual build
parameters for the source file.  This is extended to any subsequent header
opened from that header etc.. 

If the Eclipse session is closed then reopened, the defined symbol and include
path information is no longer known.
Comment 1 Jeff Johnston 2006-09-13 16:57:26 EDT
The cause of the problem is that the include chain was using a session property
for the file which gets obliterated upon closing the session.  A fix has been
made to use a persistent property.

Note You need to log in before you can comment on or make changes to this bug.