Bug 206218 - audit2allow -l does not work
Summary: audit2allow -l does not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-13 00:24 UTC by Yuichi Nakamura
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-28 20:04:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It will recognize load policy audit message (786 bytes, patch)
2006-09-13 00:24 UTC, Yuichi Nakamura
no flags Details | Diff

Description Yuichi Nakamura 2006-09-13 00:24:43 UTC
Description of problem:
audit2allow -l option does not work. 
It seems that avc.py should be modified because of change of kernel.
Patch is attached.

Version-Release number of selected component (if applicable):
1.30.10-2.fc5

How reproducible:
Steps to Reproduce:
1. Make any access denial by SELinux
2. # load_policy
3. audit2allow -al 
  
Actual results: 
Nothing generated

Expected results:
allow statement should be generated related to step 1.

Additional info:
I also reported this problem following theread.
https://www.redhat.com/archives/fedora-selinux-list/2006-September/msg00017.html

Many Japanese users are taught to use -l option, so I assigned high severity for
this problem.

Comment 1 Yuichi Nakamura 2006-09-13 00:24:43 UTC
Created attachment 136125 [details]
It will recognize load policy audit message

Comment 2 Daniel Walsh 2006-09-18 20:03:18 UTC
Fixed in policycoreutils-1.30.29-3

Comment 3 Daniel Walsh 2007-03-28 20:04:04 UTC
Closing bugs



Note You need to log in before you can comment on or make changes to this bug.