Bug 206224 - Udev kernel rules need to remove the Infiniband specific rules
Udev kernel rules need to remove the Infiniband specific rules
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 21:26 EDT by Doug Ledford
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: udev-095-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 06:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2006-09-12 21:26:53 EDT
+++ This bug was initially created as a clone of Bug #206223 +++

The default 50-udev.rules file includes the following lines:

KERNEL=="umad*",                NAME="infiniband/%k", MODE="0660"
KERNEL=="issm*",                NAME="infiniband/%k", MODE="0660"
KERNEL=="uverbs*",              NAME="infiniband/%k", MODE="0660"
KERNEL=="ucm*",                 NAME="infiniband/%k", MODE="0660"
KERNEL=="rdma_cm",              NAME="infiniband/%k", MODE="0660"


The Infiniband support now requires the openib base module for any of the other
user space components to work, and that rpm contains the file 90-openib.rules
that has the authoritative list of rules that are needed to work with our
shipping Infiniband support.  The duplicate rules should be removed from udev,
especially since there are some with incorrect permissions, which implies that
the rules need fixed anyway, so might as well just leave them out and let the
openib rules file be authoritative.
Comment 1 Harald Hoyer 2006-09-25 09:41:46 EDT
finally :)

Note You need to log in before you can comment on or make changes to this bug.