Bug 206236 - scim: right click when in pre-edit state or candidate phrases window is on, content in buffer got lost
scim: right click when in pre-edit state or candidate phrases window is on, c...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim-chewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
: i18n
: 220573 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 01:15 EDT by Xiaohong Wang
Modified: 2008-03-03 04:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-03 04:15:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaohong Wang 2006-09-13 01:15:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):
scim-chewing-0.3.1-4.fc6

How reproducible:
always

Steps to Reproduce:
1.launch gedit/openoffice
2.activate scim-chewing, ctrl-SPACE
3.enter c93s84193tj0「space」  (海納百川)
4.right click in gedit/openoffice
  
Actual results:
all content in buffer got lost

Expected results:
nothing happens, content in buffer shouldn't got lost

Additional info:
this works correct in Windows with win32-chewing-0.3.3.2
Comment 1 Caius Chance 2006-10-01 22:41:45 EDT
The preedit buffer lost as when user do right-click, it is recognised focused
out, which triggered chewing_handle_Esc().
Comment 2 Caius Chance 2006-10-02 03:33:55 EDT
Observation on the following IMEs, they all have the same behavior:

1. Chewing
2. Cangjie 5
3. Jyutping
4. Smart Pinyin
5. Cantonese Pinyin

The buffer clearance is common on scim when right click ic clicked. There is
cases occasionally reproduceable that clear preedit buffer has not been
refreshed on screen.

According to chewing upstream, it is their direction to clear preedit buffer
when scim is focus out. Also, win32-chewing are on separated development stream.

-----

FYI, gcin keeps preedit buffer when right clicked, but it is OnTheSpot compared
to scim OverTheSpot.
Comment 3 Caius Chance 2006-10-02 19:57:55 EDT
* Obsoleted comment #1.

-----

Description of problem:


Version-Release number of selected component (if applicable):
scim-1.4.4-34.fc6

How reproducible:
80%-90%

Steps to Reproduce:
1.launch gedit/openoffice
2.activate scim-chewing, ctrl-SPACE
3.enter c93s84193tj0「space」  (海納百川)
4.right click in gedit/openoffice
  
Actual results:
all content in buffer got lost

Expected results:
nothing happens, content in buffer shouldn't got lost

Additional info:
win32-chewing-0.3.3.2 is separated individual development stream.
Comment 4 Jens Petersen 2007-10-09 03:13:05 EDT
*** Bug 220573 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2007-10-09 03:14:04 EDT
Also happens for other Japanese and Chinese IMEs, so this does not seem
to be specific to scim-chewing.
Comment 6 Peng Huang 2008-03-03 04:15:06 EST
I tested gedit and openoffice. When user click right button, the app will call
gtk_im_context_reset to reset im context. I think the apps' behavior is correct.
Clicking right button without commiting preedit string is not normal. So I will
mark it as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.