Bug 206247 - Bad: packages install / update / upgrade fails with message: "Error: Missing Dependency: rtld(GNU_HASH) is needed by package..."
Bad: packages install / update / upgrade fails with message: "Error: Missing ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 04:23 EDT by ionut
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 03:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of yum -y update (1.12 MB, application/octet-stream)
2006-09-13 15:20 EDT, ionut
no flags Details

  None (edit)
Description ionut 2006-09-13 04:23:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Description of problem:
Problem is related to packages installation, update or upgrade. At first i had this problem on a FC4 when i attempted to make an update or upgrade to FC5. Both cases behaved the same way. Update was made via yum. There were multiple attempts to update / upgrade with standard fedora repos, with other than standard fedora repos and with standard fedora repos and other repos. I've made the upgrade from FC4 to FC5 using the FC5 cds and hoping that the issue will be resolved. Upgrade was successfull but still i cannot update or install some packages. Despite this problem i've managed to install a new kernel. 

Problem is that when updating (using yum or other method) headers are downloaded, dependencies are verified, other header are downloaded, dependencies are verified again, but in the end i endup with this log output:

Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package imlib
Error: Missing Dependency: rtld(GNU_HASH) is needed by package freeglut
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libsndfile
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libsamplerate
Error: Missing Dependency: xorg-x11-devel is needed by package qt-devel
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libtunepimp
Error: Missing Dependency: rtld(GNU_HASH) is needed by package xosd
Error: Missing Dependency: rtld(GNU_HASH) is needed by package valknut
Error: Missing Dependency: rtld(GNU_HASH) is needed by package glib
Error: Missing Dependency: libnetsnmp.so.5 is needed by package kdeutils
Error: Missing Dependency: rtld(GNU_HASH) is needed by package xscreensaver-base
Error: Missing Dependency: libssl.so.5 is needed by package kdenetwork
Error: Missing Dependency: rtld(GNU_HASH) is needed by package python-crypto
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libid3tag
Error: Missing Dependency: rtld(GNU_HASH) is needed by package portaudio
Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package compat-wxGTK2
Error: Missing Dependency: libssl.so.5 is needed by package kdebase
Error: Missing Dependency: rtld(GNU_HASH) is needed by package imlib2
Error: Missing Dependency: rtld(GNU_HASH) is needed by package compat-wxGTK2
Error: Missing Dependency: libdbus-1.so.1 is needed by package kdebase
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libmodplug
Error: Missing Dependency: rtld(GNU_HASH) is needed by package gtk+
Error: Missing Dependency: rtld(GNU_HASH) is needed by package imlib
Error: Missing Dependency: rtld(GNU_HASH) is needed by package taglib
Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package gdk-pixbuf
Error: Missing Dependency: rtld(GNU_HASH) is needed by package dclib
Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package imlib2
Error: Missing Dependency: xorg-x11-devel is needed by package kdelibs-devel
Error: Missing Dependency: rtld(GNU_HASH) is needed by package xscreensaver-extras
Error: Missing Dependency: libapr-0.so.0 is needed by package kdesdk
Error: Missing Dependency: rtld(GNU_HASH) is needed by package xmms
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libpng10
Error: Missing Dependency: libcrypto.so.5 is needed by package kdenetwork
Error: Missing Dependency: rtld(GNU_HASH) is needed by package gpgme
Error: Missing Dependency: rtld(GNU_HASH) is needed by package xmms-libs
Error: Missing Dependency: rtld(GNU_HASH) is needed by package qca-tls
Error: Missing Dependency: rtld(GNU_HASH) is needed by package openslp
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libmal
Error: Missing Dependency: rtld(GNU_HASH) is needed by package jasper
Error: Missing Dependency: rtld(GNU_HASH) is needed by package fltk
Error: Missing Dependency: rtld(GNU_HASH) is needed by package gnupg2
Error: Missing Dependency: rtld(GNU_HASH) is needed by package pth
Error: Missing Dependency: libpng12.so.0(PNG12_0) is needed by package fltk
Error: Missing Dependency: rtld(GNU_HASH) is needed by package libksba

Impact: i cannot update, upgrade or install some packages because of dependencies failure.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.run yum update in superuser mode

Actual Results:
update / install aborted

Expected Results:
update / install should have been successful

Additional info:
Problem was encountered initially on FC4. System was upgraded to FC5 using CDs. Problem persisted.
Comment 1 Paul Nasrat 2006-09-13 05:48:20 EDT
rpm --whatprovides -q 'rtld(GNU_HASH)'
glibc-2.4.90-29.i686

Are you sure you are not using a mixture of repositories - this is a feature of
rawhide and fc6 not fc5 so I'm suprised you see packages with those requires. 
Can you do something like:

script yum.out
yum -y update
(after it finishes/errors Ctrl-D to end script) and attach the resulting yum.out
to this bug as a plain text attachment.
Comment 2 ionut 2006-09-13 15:20:33 EDT
Created attachment 136193 [details]
output of yum -y update

this is the output of update command using yum.
Comment 3 ionut 2006-10-10 03:41:49 EDT
Indeed there was a mixture of packages headers in yum cache. removed current
repositories, added standard repositories, performed: yum clean all. yum, update
/ upgrade work fine now.

Note You need to log in before you can comment on or make changes to this bug.