Bug 206257 - ebtables 2.0.8 segfaults
Summary: ebtables 2.0.8 segfaults
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ebtables   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-13 10:08 UTC by Tom H.
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.0.8-0.3.rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 22:39:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom H. 2006-09-13 10:08:34 UTC
Description of problem:
segfaults when -j to user defined chain

Version-Release number of selected component (if applicable):
ebtables-2.0.8-0.5.rc1.fc5

How reproducible:
[root@bridge]# ebtables --version
ebtables v2.0.8-rc1 (November 2005)

[root@bridge]# ebtables -L
Bridge table: filter

Bridge chain: INPUT, entries: 0, policy: ACCEPT

Bridge chain: FORWARD, entries: 0, policy: ACCEPT

Bridge chain: OUTPUT, entries: 0, policy: ACCEPT

[root@bridge]# ebtables -N MY_CHAIN

[root@bridge]# ebtables -L
Bridge table: filter

Bridge chain: INPUT, entries: 0, policy: ACCEPT

Bridge chain: FORWARD, entries: 0, policy: ACCEPT

Bridge chain: OUTPUT, entries: 0, policy: ACCEPT

Bridge chain: MY_CHAIN, entries: 0, policy: ACCEPT

[root@bridge]# ebtables -A FORWARD -j MY_CHAIN

[root@bridge]# ebtables -L
Bridge table: filter

Bridge chain: INPUT, entries: 0, policy: ACCEPT

Bridge chain: FORWARD, entries: 1, policy: ACCEPT
Segmentation fault

(depend's not from which default chains is -j done (INPUT/FORWARD/OUTPUT), same 
results

I've tried "older, previous" version of ebtables (2.0.6) which works as 
expected..

Additional info:
other people reported same results in devel mailing list of ebtables(with 
different distributions), and there seems to be a patch to correct it... 
(didn't tried to compile in..)

http://article.gmane.org/gmane.linux.network.bridge.ebtables.devel/595

Comment 1 Tom "spot" Callaway 2006-09-14 22:39:49 UTC
Fixed in ebtables-2.0.8-0.3.rc2. Thanks for the report & patch.


Note You need to log in before you can comment on or make changes to this bug.