Bug 206264 - openoffice.org presentation crashes when opening a powerpoint presentation
openoffice.org presentation crashes when opening a powerpoint presentation
Status: CLOSED DUPLICATE of bug 205848
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 07:55 EDT by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 06:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-09-13 07:55:40 EDT
Description of problem:

Backtrace from the crash:

(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-20-i386
(V)    kernel is: Linux 2.6.17-1.2630.fc6 #1 SMP Wed Sep 6 16:16:03 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-3.1-i386
(VII)  accessibility is: false
(VIII) fedora release is: Fedora Core release 5.92 (FC6 Test3)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0xb7fa7000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00500000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x00194000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00111000)
	libdl.so.2 => /lib/libdl.so.2 (0x00127000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x0012b000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x0031a000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x001e0000)
	libm.so.6 => /lib/libm.so.6 (0x00142000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x001a4000)
	libc.so.6 => /lib/libc.so.6 (0x006ba000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00f7c000)
	/lib/ld-linux.so.2 (0x009d2000)
...end sample ldd details ...
0x45092cc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x202cc
0x4509b01: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x20b01
0xb7f0b420:  + 0x420 (__kernel_sigreturn + 0x0)
0xe628b7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x208b7
0xe664c3: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x244c3
(X11SalGraphics::Init(X11SalVirtualDevice*, SalColormap*, bool) + 0xe1)
0xe667fd: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x247fd
0xe667cb: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x247cb
(X11SalInstance::CreateVirtualDevice(SalGraphics*, long, long, unsigned short,
SystemGraphicsData const*) + 0xe5)
0x5d6900f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11f00f
0x5d6925d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11f25d
(VirtualDevice::VirtualDevice(SystemGraphicsData const*, unsigned short) + 0x4f)
0x1c22d19: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x20d19
0x1c237c4: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x217c4
0x1c19cde: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x17cde
0x5f4d0f3: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x310f3
0x5f3f0fc: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x230fc
0x5f3f2bf: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x232bf
(cppcanvas::internal::ImplRenderer::draw() const + 0x4f)
0x1ee0b1c: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc7b1c
0x1ee1a00: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc8a00
0x1ee1b23: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc8b23
0x1e9277f: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x7977f
0x1eaaac3: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91ac3
0x1eaaaf8: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91af8
0x1eaabcd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91bcd
0x1eaac02: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91c02
0x1eab017: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x92017
0x1eaa264: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91264
0x1eac14e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9314e
0x1ec6339: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad339
0x1ec70bd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xae0bd
0x1e5388f: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3a88f
0x1e5393e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3a93e
0x1e53dbe: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3adbe
0x1e6901e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x5001e
0x1e57a0a: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3ea0a
0x1e72ff9: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x59ff9
0x1e8461b: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x6b61b
0x1eb3d7e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9ad7e
0x2ef7fba: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2f1fba
0x2ef80d6: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2f20d6
0x5cd5e50: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8be50
0x5ce28ec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x988ec
(Timer::Timeout() + 0x1c)
0x5ce2a2a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x98a2a
(Timer::ImplTimerCallbackProc() + 0x78)
0xe80473: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e473
0xe802ac: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e2ac
(X11SalData::Timeout() const + 0x24)
0xe0f527: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13527
0xe0f54b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1354b
0x12c916: /lib/libglib-2.0.so.0 + 0x2b916
0x12c342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x12f31f: /lib/libglib-2.0.so.0 + 0x2e31f
0x12f885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0xe0f22a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1322a
0xe87a9e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45a9e
(X11SalInstance::Yield(bool, bool) + 0x2c)
0x5cde473: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94473
(Application::Yield(bool) + 0x53)
0x5cde508: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94508
(Application::Execute() + 0x28)
0x652a186: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24186
(desktop::Desktop::Main() + 0x164e)
0x5ce22de: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x982de
0x5ce23d3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x983d3 (SVMain()
+ 0x2b)
0x6523d09: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd09 (sal_main
+ 0x5d)
0x6523d55: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd55 (main + 0x27)
0xa04f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4a1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2006-09-15 06:35:10 EDT
Have you got a sample .ppt which always does this ? If so please attach to bug
205848

*** This bug has been marked as a duplicate of 205848 ***
Comment 2 Xiaohong Wang 2006-10-15 04:37:38 EDT
Verified no crash in openoffice-2.0.4-4.2 when playing slides

Note You need to log in before you can comment on or make changes to this bug.