Bug 206318 - xterm-192-4.EL4 and Exceed
xterm-192-4.EL4 and Exceed
Status: CLOSED DUPLICATE of bug 212998
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xterm (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 13:03 EDT by Dora Abdullah
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 09:33:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dora Abdullah 2006-09-13 13:03:15 EDT
Description of problem:

The problem occurs when connecting via Hummingbird Exceed v.10 to a Linux
machine with Kernel 2.6.9-42.ELsmp that has xterm-192-4.EL4. Once an XTerm
window is opened, the Backspace key mapping breaks. It cannot be set via the
following stty either:
 stty erase ^H
 stty erase '^?'

Note that the problem does not exist when connecting to a Linux machine with
Kernel 2.6.9-34.X that has xterm-192-1 using the same connection method and user
login.

Version-Release number of selected component (if applicable):
xterm-192-4.EL4

How reproducible:

Using Hummingbird Exceed v.10 via "Secure Shell" method and "xterm" command. 

Steps to Reproduce:
1. Using Exceed's Secure Shell method, connect to a Linux machine with Kernel
2.6.9-42.ELsmp and has xterm-192-4.EL4.
2. Backspace key no longer works, nor can it be set via stty erase.
3.
  
Actual results:


Expected results:


Additional info: The problem does not exist when connecting to a Linux machine
with Kernel 2.6.9-34.X that has xterm-192-1 using the same connection method and
user login.
Comment 1 Miroslav Lichvar 2006-11-16 09:33:10 EST
The problem is probably caused by backarrowKey resource, which was changed in
the last update.

To fix it, delete line "*VT100*backarrowKey: false" in file
/usr/X11R6/lib/X11/app-defaults/XTerm.

*** This bug has been marked as a duplicate of 212998 ***

Note You need to log in before you can comment on or make changes to this bug.