Bug 206334 - smartctl and smartd are unable to autodetect SATA
smartctl and smartd are unable to autodetect SATA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Smetana
Brian Brock
:
: 176835 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 14:52 EDT by Milan Kerslager
Modified: 2008-09-30 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0763
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2006-09-13 14:52:04 EDT
Both smartctl and smartd are unable to autodetect SATA discs.

smartctl needs "-d ata" parameter to work with SATA discs

smartd does not check SATA discs even configured to do on all discs in the system

This bug prevent users to check and monitor SATA discs which is unacceptable in
enterprise environment.
Comment 1 Tomas Mraz 2006-10-31 07:15:01 EST
The smartd-conf.py script in the current packages should be able to autodetect
the SATA disc and add the '-d ata' option where appropriate. Doesn't it work for
you?
Comment 2 Antonio Gallardo 2007-04-05 16:07:33 EDT
in Fedora 6, the '-d ata' works fine for my SATA disk.
Package: smartmontools-5.36-3.2.fc6

Here is the output if the -d ata option was not provided in the command line.
Note the last paragraph is suggesting to use it:

# /usr/sbin/smartctl -i /dev/sda
smartctl version 5.36 [i386-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Device: ATA      WDC WD2500KS-00M Version: 02.0

In Linux, SATA disks accessed via libata are only supported by smartmontools
for kernel versions 2.6.15 and above. Try an additional '-d ata' argument.

Now, lets run it using the '-d ata':

# /usr/sbin/smartctl -i /dev/sda -d ata
smartctl version 5.36 [i386-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Device Model:     WDC WD2500KS-00MJB0
Serial Number:    WD-WCANK4707515
Firmware Version: 02.01C03
User Capacity:    250,059,350,016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   7
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Thu Apr  5 13:45:18 2007 CST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
Comment 3 Tomas Smetana 2007-04-19 10:28:58 EDT
Seems to be working fine for me. Can you post your /etc/smartd.conf and provide
some details (how many disks are there in the system, manufacturers of disks,...)?
Comment 4 Milan Kerslager 2007-04-20 02:07:03 EDT
Smartd does not work with SATA discs without '-d ata' (see comment #1), ie with
alone DEVICESCAN. Anaconda is putting lines like and the monitoring seems then
as working:

/dev/sdg -d ata -H -m root

I was using this line:

DEVICESCAN -a -m root -M daily -s
(O/../.././(00|06|12|18)|S/../.././(03|09|15|21)|L/../.././01)
Comment 5 Tomas Smetana 2007-04-23 09:24:19 EDT
Thanks Milan. Now it's clear. Smartmontools indeed can't distinguish among
SCSI/SATA/SAT disk types. This is what the configuration script is supposed to
do. I can try to move the "detection code" from script into the binaries.
Comment 6 Tomas Smetana 2007-04-26 09:09:38 EDT
From version 5.37 smartmontools detect ATA discs behind SAT layer automatically.
Comment 7 RHEL Product and Program Management 2007-05-09 05:37:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 errata-xmlrpc 2007-11-15 11:00:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0763.html
Comment 13 Michal Hlavinka 2008-09-30 10:18:14 EDT
*** Bug 176835 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.