Bug 2063502 - F36FailsToInstall: Multiple packages built from baresip
Summary: F36FailsToInstall: Multiple packages built from baresip
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: baresip
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F36FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-03-13 09:43 UTC by Miro Hrončok
Modified: 2022-03-26 15:20 UTC (History)
1 user (show)

Fixed In Version: baresip-2.0.0-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-26 15:20:55 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2022-03-13 09:43:58 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (baresip) Fails To Install in Fedora 36:

can't install baresip:
  - nothing provides libre.so.1()(64bit) needed by baresip-1.1.0-8.fc36.x86_64
  - nothing provides librem.so.0()(64bit) needed by baresip-1.1.0-8.fc36.x86_64
  
can't install baresip-aac:
  - nothing provides libre.so.1()(64bit) needed by baresip-aac-1.1.0-8.fc36.x86_64
  
can't install baresip-alsa:
  - nothing provides libre.so.1()(64bit) needed by baresip-alsa-1.1.0-8.fc36.x86_64
  
can't install baresip-codec2:
  - nothing provides libre.so.1()(64bit) needed by baresip-codec2-1.1.0-8.fc36.x86_64
  
can't install baresip-ctrl_dbus:
  - nothing provides libre.so.1()(64bit) needed by baresip-ctrl_dbus-1.1.0-8.fc36.x86_64
  
can't install baresip-g722:
  - nothing provides libre.so.1()(64bit) needed by baresip-g722-1.1.0-8.fc36.x86_64
  
can't install baresip-g726:
  - nothing provides libre.so.1()(64bit) needed by baresip-g726-1.1.0-8.fc36.x86_64
  
can't install baresip-gsm:
  - nothing provides libre.so.1()(64bit) needed by baresip-gsm-1.1.0-8.fc36.x86_64
  
can't install baresip-gst:
  - nothing provides libre.so.1()(64bit) needed by baresip-gst-1.1.0-8.fc36.x86_64
  
can't install baresip-gst_video:
  - nothing provides libre.so.1()(64bit) needed by baresip-gst_video-1.1.0-8.fc36.x86_64
  
can't install baresip-gtk:
  - nothing provides libre.so.1()(64bit) needed by baresip-gtk-1.1.0-8.fc36.x86_64
  
can't install baresip-jack:
  - nothing provides libre.so.1()(64bit) needed by baresip-jack-1.1.0-8.fc36.x86_64
  
can't install baresip-mpa:
  - nothing provides libre.so.1()(64bit) needed by baresip-mpa-1.1.0-8.fc36.x86_64
  
can't install baresip-mqtt:
  - nothing provides libre.so.1()(64bit) needed by baresip-mqtt-1.1.0-8.fc36.x86_64
  
can't install baresip-omx:
  - nothing provides libre.so.1()(64bit) needed by baresip-omx-1.1.0-8.fc36.x86_64
  
can't install baresip-opus:
  - nothing provides libre.so.1()(64bit) needed by baresip-opus-1.1.0-8.fc36.x86_64
  
can't install baresip-plc:
  - nothing provides libre.so.1()(64bit) needed by baresip-plc-1.1.0-8.fc36.x86_64
  
can't install baresip-portaudio:
  - nothing provides libre.so.1()(64bit) needed by baresip-portaudio-1.1.0-8.fc36.x86_64
  
can't install baresip-pulse:
  - nothing provides libre.so.1()(64bit) needed by baresip-pulse-1.1.0-8.fc36.x86_64
  
can't install baresip-rst:
  - nothing provides libre.so.1()(64bit) needed by baresip-rst-1.1.0-8.fc36.x86_64
  
can't install baresip-sdl:
  - nothing provides libre.so.1()(64bit) needed by baresip-sdl-1.1.0-8.fc36.x86_64
  
can't install baresip-snapshot:
  - nothing provides libre.so.1()(64bit) needed by baresip-snapshot-1.1.0-8.fc36.x86_64
  
can't install baresip-sndfile:
  - nothing provides libre.so.1()(64bit) needed by baresip-sndfile-1.1.0-8.fc36.x86_64
  
can't install baresip-speex_pp:
  - nothing provides libre.so.1()(64bit) needed by baresip-speex_pp-1.1.0-8.fc36.x86_64
  
can't install baresip-v4l2:
  - nothing provides libre.so.1()(64bit) needed by baresip-v4l2-1.1.0-8.fc36.x86_64
  
can't install baresip-vp8:
  - nothing provides libre.so.1()(64bit) needed by baresip-vp8-1.1.0-8.fc36.x86_64
  
can't install baresip-vp9:
  - nothing provides libre.so.1()(64bit) needed by baresip-vp9-1.1.0-8.fc36.x86_64
  
can't install baresip-x11:
  - nothing provides libre.so.1()(64bit) needed by baresip-x11-1.1.0-8.fc36.x86_64
  
can't install baresip-x11grab:
  - nothing provides libre.so.1()(64bit) needed by baresip-x11grab-1.1.0-8.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-36-x86_64 --disablerepo='*' --enablerepo=local install baresip baresip-aac baresip-alsa baresip-codec2 baresip-ctrl_dbus baresip-g722 baresip-g726 baresip-gsm baresip-gst baresip-gst_video baresip-gtk baresip-jack baresip-mpa baresip-mqtt baresip-omx baresip-opus baresip-plc baresip-portaudio baresip-pulse baresip-rst baresip-sdl baresip-snapshot baresip-sndfile baresip-speex_pp baresip-v4l2 baresip-vp8 baresip-vp9 baresip-x11 baresip-x11grab


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2022-03-13 11:05:53 UTC
FEDORA-2022-7814b1e12f has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-7814b1e12f

Comment 2 Fedora Update System 2022-03-13 15:34:26 UTC
FEDORA-2022-7814b1e12f has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-7814b1e12f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-7814b1e12f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-03-26 15:20:55 UTC
FEDORA-2022-7814b1e12f has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.