Bug 206364 - DHCPv6 server does not delegate prefix
DHCPv6 server does not delegate prefix
Status: CLOSED DUPLICATE of bug 206362
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 17:21 EDT by Ganesh Natarajan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 11:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ganesh Natarajan 2006-09-13 17:21:26 EDT
Description of problem:
I am using dhcpv6 server on fedora core 3 linux for i386. The dhcp6s server is 
updated to dhcp6s-0.10-14_FC3.rpm. When I connect a cisco 7301 router as a 
client to the DHCPv6 server, the server does not return a valid prefix. I 
notice in the log the following.

Sep/11/2006 11:19:54 received solicit from fe80::200:ff:fe02:301%vlan1401
Sep/11/2006 11:19:54 get DHCP option opt_8, len 2
Sep/11/2006 11:19:54  this message elapsed time is: 1528
Sep/11/2006 11:19:54 get DHCP option client ID, len 10
Sep/11/2006 11:19:54   DUID: 00:03:00:01:00:00:00:09:02:01
Sep/11/2006 11:19:54 get DHCP option rapid commit, len 0
Sep/11/2006 11:19:54 get DHCP option option request, len 6
Sep/11/2006 11:19:54   requested option: DNS_RESOLVERS
Sep/11/2006 11:19:54   requested option: opt_23
Sep/11/2006 11:19:54   requested option: opt_24
Sep/11/2006 11:19:54 get DHCP option DNS_RESOLVERS, len 12
Sep/11/2006 11:19:54 malformed DHCP option: type 25, len 12
Sep/11/2006 11:19:54 DUID is 00:03:00:01:00:00:00:09:02:01, DUID_LEN is 10
Sep/11/2006 11:19:54 removing ID (ID: 00:03:00:01:00:00:00:09:02:01)
Sep/11/2006 11:19:54 DUID is , DUID_LEN is 0
Sep/11/2006 11:19:54 failed to parse options

Version-Release number of selected component (if applicable):

fedora core Linux. DHCPv6-0.14-FC3.rpm


How reproducible:
Start dhcp6s server. Connect dhcp6s client using cisco 7301 which has prefix 
enabled. 

Steps to Reproduce:
1.Same as above
2.
3.
  
Actual results:
Sep/11/2006 11:19:54 received solicit from fe80::200:ff:fe02:301%vlan1401
Sep/11/2006 11:19:54 get DHCP option opt_8, len 2
Sep/11/2006 11:19:54  this message elapsed time is: 1528
Sep/11/2006 11:19:54 get DHCP option client ID, len 10
Sep/11/2006 11:19:54   DUID: 00:03:00:01:00:00:00:09:02:01
Sep/11/2006 11:19:54 get DHCP option rapid commit, len 0
Sep/11/2006 11:19:54 get DHCP option option request, len 6
Sep/11/2006 11:19:54   requested option: DNS_RESOLVERS
Sep/11/2006 11:19:54   requested option: opt_23
Sep/11/2006 11:19:54   requested option: opt_24
Sep/11/2006 11:19:54 get DHCP option DNS_RESOLVERS, len 12
Sep/11/2006 11:19:54 malformed DHCP option: type 25, len 12
Sep/11/2006 11:19:54 DUID is 00:03:00:01:00:00:00:09:02:01, DUID_LEN is 10
Sep/11/2006 11:19:54 removing ID (ID: 00:03:00:01:00:00:00:09:02:01)
Sep/11/2006 11:19:54 DUID is , DUID_LEN is 0
Sep/11/2006 11:19:54 failed to parse options


Expected results:
DHCPv6 server should send a valid network prefix in the Advertise message back 
to the client.

Additional info: The configuration file used is as follows. 

interface vlan1401 {
        server-preference 255;
        renew-time 60;
        rebind-time 90;
        prefer-life-time 130;
        valid-life-time 200;
        allow rapid-commit;
        option dns_servers 2000::2 ibm.com;
        link AAA {
                pool{
                        range 2001:1:2::2 to 2001:1:2::100/64;
                        prefix 2001:1:2::/48;
                };
        };
        host BBB {
                duid 00:01:00:01:0b:da:ce:01:00:12:3f:f1:bd:5e;
#               duid 00:01:00:01:05:c8:8c:7e:00:10:a4:8d:30:7f;
                iaidinfo {
                        iaid  8335501;
                        renew-time 30;
                        rebind-time 40;
                };
                prefix {
                        fecc::/24;
                        prefer-life-time 90;
                        valid-life-time 120;
                };
                prefix {
                        3000::/64;
                        prefer-life-time 100;
                        valid-life-time 120;
                };
                address {
                        fecc::1/34;
                        prefer-life-time 60;
                        valid-life-time 90;
                };
        };
};
Comment 1 David Cantrell 2006-09-14 11:06:07 EDT

*** This bug has been marked as a duplicate of 206362 ***

Note You need to log in before you can comment on or make changes to this bug.