Bug 206366 - [RHEL5 Beta1]: sysrq-t incurs a bogus softlockup warning
[RHEL5 Beta1]: sysrq-t incurs a bogus softlockup warning
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Brian Brock
:
: 213064 (view as bug list)
Depends On:
Blocks: 228988
  Show dependency treegraph
 
Reported: 2006-09-13 17:27 EDT by Kiyoshi Ueda
Modified: 2010-10-22 02:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:13:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console log of when sysreport is running (205.81 KB, text/plain)
2006-09-13 17:27 EDT, Kiyoshi Ueda
no flags Details
Upstream fix for this issue (1.87 KB, patch)
2007-03-13 13:47 EDT, Prarit Bhargava
no flags Details | Diff
RHEL5 fix for this issue (2.28 KB, patch)
2007-03-13 13:49 EDT, Prarit Bhargava
no flags Details | Diff
RHEL5 fix for this issue (2.28 KB, patch)
2007-03-13 13:54 EDT, Prarit Bhargava
no flags Details | Diff
Upstream fix for this issue (1.96 KB, patch)
2007-03-13 13:55 EDT, Prarit Bhargava
no flags Details | Diff
Upstream fix for this issue (5.46 KB, patch)
2007-03-14 14:44 EDT, Prarit Bhargava
no flags Details | Diff
RHEL5 fix for this issue (9.03 KB, patch)
2007-03-14 14:45 EDT, Prarit Bhargava
no flags Details | Diff
RHEL5 fix for this issue (2.21 KB, patch)
2007-04-04 08:06 EDT, Prarit Bhargava
no flags Details | Diff
RHEL5 fix for this issue (2.21 KB, application/octet-stream; charset=ISO-8859-1)
2007-08-10 18:43 EDT, IBM Bug Proxy
no flags Details
Console log of when sysreport is running (205.81 KB, text/plain)
2007-08-10 18:43 EDT, IBM Bug Proxy
no flags Details
Upstream fix for this issue (5.46 KB, text/plain)
2007-08-10 18:43 EDT, IBM Bug Proxy
no flags Details
RHEL5 fix for this issue (9.03 KB, application/octet-stream; charset=ISO-8859-1)
2007-08-10 18:43 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 30021 None None None Never

  None (edit)
Description Kiyoshi Ueda 2006-09-13 17:27:15 EDT
Description of problem:
kernel BUG() is caused by sysreport on IA64 SMP box.


Version-Release number of selected component:
kernel-2.6.17-1.2519.4.21.el5
kernel-2.6.17-1.2519.4.26.el5
sysreport-1.4.3-8


How reproducible:
Always


Steps to Reproduce:
 1. Run sysreport on IA64 SMP box


Actual results:
kernel BUG() occurs.


Expected results:
kernel BUG() should not occur.


Additional info:
Console log during sysreport is attached.
Comment 1 Kiyoshi Ueda 2006-09-13 17:27:16 EDT
Created attachment 136213 [details]
Console log of when sysreport is running
Comment 2 Kiyoshi Ueda 2006-09-13 17:38:01 EDT
I found that this problem can be reproduced by
'echo t > /proc/sysrq-trigger'.
Comment 3 Kiyoshi Ueda 2006-09-14 13:11:51 EDT
Serial console may be required to reproduce this problem.

On a IA64 box which has 16CPU and uses serial console,
I can reproduce this problem.
But I can't on a x86_64 box which has 16CPU and uses VGA console.
Comment 5 RHEL Product and Program Management 2006-10-26 16:13:42 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Daniel Riek 2007-01-03 21:34:25 EST
Does the problem persist in current snapshots? Please verify.
Comment 9 Kiyoshi Ueda 2007-01-04 09:55:00 EST
Yes, it is.
It still occurs in the kernel-2.6.18-1.2961.el5.

By the way, I confirmed the "BUG" message is printed by
softlockup_tick() instead of BUG().
So it isn't a panic and the system can continue to work.
I change the severity to "normal".
Comment 10 Prarit Bhargava 2007-03-13 13:44:14 EDT
*** Bug 213064 has been marked as a duplicate of this bug. ***
Comment 11 Prarit Bhargava 2007-03-13 13:45:56 EDT
The issue here is that show_state acquires the tasklist_lock for an extended
period of time.  After show_state is done, the first cpu "freed" will take a
timer interrupt which then spits out a bogus message that there was a softlockup.
Comment 12 Prarit Bhargava 2007-03-13 13:47:49 EDT
Created attachment 149958 [details]
Upstream fix for this issue
Comment 13 Prarit Bhargava 2007-03-13 13:49:09 EDT
Created attachment 149959 [details]
RHEL5 fix for this issue
Comment 14 Prarit Bhargava 2007-03-13 13:54:28 EDT
Created attachment 149961 [details]
RHEL5 fix for this issue
Comment 15 Prarit Bhargava 2007-03-13 13:55:57 EDT
Created attachment 149963 [details]
Upstream fix for this issue
Comment 17 Prarit Bhargava 2007-03-14 14:44:47 EDT
Created attachment 150074 [details]
Upstream fix for this issue
Comment 18 Prarit Bhargava 2007-03-14 14:45:40 EDT
Created attachment 150075 [details]
RHEL5 fix for this issue
Comment 19 Prarit Bhargava 2007-03-15 09:25:25 EDT
Sent to lkml.

P.
Comment 20 Prarit Bhargava 2007-03-15 10:13:17 EDT
Upstream here:

http://lkml.org/lkml/2007/3/15/131
Comment 21 IBM Bug Proxy 2007-03-25 15:52:09 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|FIXEDAWAITINGTEST           |TESTED




------- Additional Comments From nevdull@us.ibm.com (prefers email at ricklind@us.ibm.com)  2007-03-25 15:49 EDT -------
Received notification from Andrew Morton today that the patch has been committed
to the -mm tree.  I'd expect a new -mm tree to be out sometime this week. 
Comment 22 RHEL Product and Program Management 2007-03-25 19:41:45 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 23 Prarit Bhargava 2007-04-04 08:06:56 EDT
Created attachment 151651 [details]
RHEL5 fix for this issue
Comment 24 Don Zickus 2007-05-11 18:10:09 EDT
in 2.6.18-19.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 25 IBM Bug Proxy 2007-07-10 17:55:24 EDT
----- Additional Comments From nevdull@us.ibm.com (prefers email at ricklind@us.ibm.com)  2007-07-10 17:49 EDT -------
This remains open on the RH side, so it's not clear if this was intended to be
fixed in RHEL5 or not.  Is there either testing or inspection that needs to
happen here? 
Comment 26 Prarit Bhargava 2007-07-10 18:14:20 EDT
This has been fixed in RHEL5.

P.
Comment 27 IBM Bug Proxy 2007-07-10 19:01:10 EDT
----- Additional Comments From nevdull@us.ibm.com (prefers email at ricklind@us.ibm.com)  2007-07-10 18:59 EDT -------
Thank you for the fast reply, prarit. 
Comment 29 Mike Gahagan 2007-07-30 13:48:51 EDT
verified the patch is in the -36 kernel.
Comment 30 IBM Bug Proxy 2007-07-30 22:45:18 EDT
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2007-07-30 22:41 EDT -------
Hi Mike, So can we close the bug on our end? Thanks. 
Comment 31 IBM Bug Proxy 2007-08-10 18:43:04 EDT
Created attachment 161096 [details]
RHEL5 fix for this issue
Comment 32 IBM Bug Proxy 2007-08-10 18:43:12 EDT
Created attachment 161097 [details]
Console log of when sysreport is running
Comment 33 IBM Bug Proxy 2007-08-10 18:43:19 EDT
Created attachment 161098 [details]
Upstream fix for this issue
Comment 34 IBM Bug Proxy 2007-08-10 18:43:26 EDT
Created attachment 161099 [details]
RHEL5 fix for this issue
Comment 36 errata-xmlrpc 2007-11-07 14:13:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.