Bug 206427 - LTC26985-[LSPP Audit] auditctl fails to reject malformed ARCH filter
LTC26985-[LSPP Audit] auditctl fails to reject malformed ARCH filter
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 07:33 EDT by Issue Tracker
Modified: 2009-06-19 05:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 09:50:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Issue Tracker 2006-09-14 07:33:43 EDT
Escalated to Bugzilla from IssueTracker
Comment 2 Eric Paris 2006-09-28 13:59:33 EDT
I sent an e-mail directly to the ibm reporter to ask this question (since I was
apparently supposed to have all this fixed by last monday) but should follow
process as well.

By "invalid" do they mean the usage of > or < ?  I assume they believe that only
= or != should be allowed?  If so this should be done in userspace in the
auditctl utility in audit_rule_fieldpair_data() by returning -12 and explaining
it in an error inside setopt.   This should not be a kernel fix.
Comment 3 Steve Grubb 2006-09-28 14:06:51 EDT
only = and != are valid for arch field. This needs to be in the kernel since
anyone could use an old audit tool or write their own.
Comment 4 Jay Turner 2006-09-29 12:45:49 EDT
QE ack for RHEL5B2.  Related to 14b of the release criteria.
Comment 5 Linda Wang 2006-09-29 14:35:22 EDT
patch posted for revew on 9/29.
Comment 6 Don Zickus 2006-10-09 17:48:56 EDT
in kernel-2.6.18-1.2718.el5

Note You need to log in before you can comment on or make changes to this bug.