Bug 206456 - Sort does not always sort right.
Sort does not always sort right.
Status: CLOSED DUPLICATE of bug 144541
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 10:31 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 12:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-09-14 10:31:46 EDT
Description of problem:
Lines starting with an asterisk sometimes get sorted strangely:

$ echo -e "a\nc\n*\nb" | sort
*
a
b
c

This is the expected behaviour. Now a different string:

$ echo -e "eutin: lall\nfhansen: keks\n*: :fail:" | sort
eutin: lall
*: :fail:
fhansen: keks

The line starting with * is put between e and f, strange enough.

$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


Version-Release number of selected component (if applicable):
coreutils-5.97-9

How reproducible:
Sometimes (depends on text to be sorted)

Steps to Reproduce:
1. Sort a text containing lines starting with *
2.
3.
  
Actual results:
Sometimes * gets sorted between e and f

Expected results:
Lines with * at the beginning (or the end)

Additional info:
Also happens on CentOS 4.4 with coreutils-5.2.1-31.4
Comment 1 Tim Waugh 2006-09-26 12:07:42 EDT

*** This bug has been marked as a duplicate of 144541 ***

Note You need to log in before you can comment on or make changes to this bug.