This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 206515 - checkpoint reference count off causes assertion
checkpoint reference count off causes assertion
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.0
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Steven Dake
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 15:51 EDT by Steven Dake
Modified: 2016-04-26 10:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2006-09-14 15:51:08 EDT
Description of problem:
segfault in checkpoint service

Version-Release number of selected component (if applicable):
openais-0.80-1.0

How reproducible:
not very reproducible

Steps to Reproduce:
1. run revolver test for a day
2.

3.

(gdb) where
#0  0xb7fc2402 in ?? ()
#1  0x0098e050 in raise () from /lib/libc.so.6
#2  0x0098f8a1 in abort () from /lib/libc.so.6
#3  0x0098769b in __assert_fail () from /lib/libc.so.6
#4  0x00d45ae5 in message_handler_req_exec_ckpt_checkpointclose (
    message=0xb749d011, nodeid=5) at ckpt.c:2348
#5  0x08062716 in deliver_fn (nodeid=5, iovec=0xbfd9c3b0, iov_len=1,
    endian_conversion_required=0) at main.c:355
#6  0x0805cf02 in app_deliver_fn (nodeid=5, iovec=0x8079148, iov_len=1,
    endian_conversion_required=0) at totempg.c:395
#7  0x0805ccd8 in totempg_deliver_fn (nodeid=5, iovec=0x8d447b4, iov_len=1,
    endian_conversion_required=0) at totempg.c:553
#8  0x0805c0a3 in totemmrp_deliver_fn (nodeid=5, iovec=0x8d447b4, iov_len=1,
    endian_conversion_required=0) at totemmrp.c:81
#9  0x08059bdb in messages_deliver_to_app (instance=0x8d0da58, skip=0,
    end_point=163) at totemsrp.c:3448
#10 0x0805a026 in message_handler_mcast (instance=0x8d0da58, msg=0x8d49628,
    msg_len=417, endian_conversion_needed=0) at totemsrp.c:3585
#11 0x0805beed in main_deliver_fn (context=0x8d0da58, msg=0x8d49628,
    msg_len=417) at totemsrp.c:4023
#12 0x080505d6 in none_mcast_recv (rrp_instance=0x8d07e78, iface_no=0,
    context=0x8d0da58, msg=0x8d49628, msg_len=417) at totemrrp.c:476
#13 0x08051f2c in rrp_deliver_fn (context=0x8d076f8, msg=0x8d49628,
---Type <return> to continue, or q <return> to quit---
    msg_len=417) at totemrrp.c:1319
#14 0x0804e6a4 in net_deliver_fn (handle=0, fd=5, revents=1, data=0x8d48fd8)
    at totemnet.c:679
#15 0x0804cbee in poll_run (handle=0) at aispoll.c:402
#16 0x08063052 in main () at main.c:562
(gdb) up
#1  0x0098e050 in raise () from /lib/libc.so.6
(gdb) up
#2  0x0098f8a1 in abort () from /lib/libc.so.6
(gdb) up
#3  0x0098769b in __assert_fail () from /lib/libc.so.6
(gdb) up
#4  0x00d45ae5 in message_handler_req_exec_ckpt_checkpointclose (
    message=0xb749d011, nodeid=5) at ckpt.c:2348
2348            assert (checkpoint->referenceCount > 0); /*defect 1192*/
(gdb) print checkpoint->referenceCount
$1 = 0
(gdb) print *checkpoint
$3 = {list = {next = 0xd4c1c8, prev = 0x8d65698}, name = {length = 13,
    value =
"gfsplock.soot\000_\000\000\000\000\000\000\000\000\000�\037m\000\000\000\000\000\000\000\000\000\035�_\000\214���
�%\b\036�%\b�����\037m\000\214��� �%\bx���$\227_\000\214���ܿ\005\b����
�%\b\000\000\000\000,����\000\000\000\001\200�� �%\b �%\b �%\b �%\bW�%\b\036�%\b
�%\b\036�%\b", '\0' <repeats 68 times>, "����", '\0' <repeats 12 times>, "����",
'\0' <repeats 20 times>, "\021\000\000\000@\031m"}, ckpt_id = 0,
checkpoint_creation_attributes = {
    creation_flags = 1, checkpoint_size = 0,
    retention_duration = 9223372036854775807, max_sections = 1,
    max_section_size = 0, max_section_id_size = 22}, sections_list_head = {
    next = 0x8d5b6d8, prev = 0x8d5b6d8}, referenceCount = 0, unlinked = 0,
  retention_timer = 0x0, expired = 0, active_replica_set = 1,
  sectionCount = 0, ckpt_refcnt = {{count = 0,
      nodeid = 0} <repeats 384 times>}}


Actual results:
segfault

Expected results:
no segfault

Additional info:
Comment 1 Steven Dake 2006-09-14 15:57:02 EDT
request beta blocker
Comment 2 Rob Kenna 2006-09-14 16:08:25 EDT
PM Ack.  Steve you should have dev ack'd already (since you requested inclusion)
Comment 4 Steven Dake 2006-10-16 12:25:32 EDT
Fixed in openais-0.80.1-7 in the RHEL5 branch.

Note You need to log in before you can comment on or make changes to this bug.