Bug 206564 - wildcard extraction seems to be broken
Summary: wildcard extraction seems to be broken
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tar   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-15 02:32 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 11:21:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nalin Dahyabhai 2006-09-15 02:32:28 UTC
Description of problem:
tar seems to have problems extracting files from archives when a wildcard
specifying which files to extract is given on the command line.

Version-Release number of selected component (if applicable):
1.15.91-1

How reproducible:
Always

Steps to Reproduce:
1. mkdir foo.new
2. touch foo.new/foo.bar
3. tar cvf foo.new.tar foo.new
4. tar xvf foo.new.tar "*.bar"
  
Actual results:
tar output:
  tar: Pattern matching characters used in file names. Please,
  tar: use --wildcards to enable pattern matching, or --no-wildcards to
  tar: suppress this warning.
  tar: *.bar: Not found in archive
  tar: Error exit delayed from previous errors

Expected results:
tar output:
  foo.new/foo.bar

Additional info:
If it helps, this worked in 1.15.90-7.

Comment 1 Peter Vrabec 2006-09-18 11:19:59 UTC
It's not a bug. This behavior has been changed by upstream.

more info:
http://lists.gnu.org/archive/html/bug-tar/2006-06/msg00001.html



Note You need to log in before you can comment on or make changes to this bug.