Bug 206570 - RFE: vm list from ricci
RFE: vm list from ricci
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Corey Marthaler
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-14 23:15 EDT by Jim Parsons
Modified: 2009-04-16 18:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:56:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Parsons 2006-09-14 23:15:54 EDT
When creating a xenvm/service, the UI should displayy a list of choices to the
user. This list needs to be available to luci via a ricci query, on xen capable
clusters. This list will likely be derived from a list of vm description files
on shared storage in /etc/xen, or somesuch location. There will be a default
path to these files as part of cluster suite policy, and ricci should look
there, but ricci should also take a path as an argument to this query so that
the user can specify a non-standard location somewhhere on shared storage.
Comment 1 Kiersten (Kerri) Anderson 2006-10-03 12:51:45 EDT
Devel ACK for RHEL5.0.0 Beta 2
Comment 2 RHEL Product and Program Management 2006-10-03 13:09:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 3 Jay Turner 2006-10-10 15:50:10 EDT
QE ack for RHEL5B2 according to section 21a of the release criteria.
Comment 6 Jim Parsons 2006-10-16 09:52:51 EDT
This bug is being addressed right now as follows:

Rather than having the user enter a path to a xenvm and then doing a round trip
to the server in order to show a list of available xenvm configs, we are
requiring that the user submit a path AND config file name. This is because
there is no straightforward way for ricci to identify which files in a directory
are xenvm config files -- there are three different formats available for
specifying them, and there is no consensus for the formats on file extension --
in fact, no extension is necessary. 

This will also save a server roundtrip. 

Finally, an admin is likely going to know the precise name of the config file
and where it is located before adding a xenvm through the UI.

As there is a work around for this, I am requesting that we downgrade this bug
from beta-blocker to just blocker, where we can consider if we even want ti
implement it in GA.
Comment 7 Kiersten (Kerri) Anderson 2006-10-16 10:49:08 EDT
Given the current implementation and workaround, am moving this feature out to
5.1 for consideration.  Potentially would provide more feedback to the user
about possible options and an ease of use interface.  We will not do any more
work for this feature in 5.0.
Comment 8 Kiersten (Kerri) Anderson 2007-04-23 13:08:06 EDT
Fixing Product Name.  Cluster Suite was merged into Enterprise Linux for version
5.0.
Comment 9 Jim Parsons 2007-09-12 16:52:49 EDT
The work around for this issue is working fine. No requests from customers or
users to add this list. As this was my initial idea and the ticket was meant to
keep me from forgetting this, I know feel forgetting it is best - so closing,
wont fix
Comment 10 Ryan McCabe 2008-03-19 10:23:02 EDT
This feature is needed now for the command-line conga deployment script. The
patch to add support is pretty small, and the code it adds is isolated.

Comment 11 Ryan McCabe 2008-03-24 11:15:01 EDT
moving to clustermon. the code to fix the bug ended up in modclusterd, which is
provided by clustermon.
Comment 16 Brian Brock 2008-12-16 18:25:54 EST
verified
Comment 18 errata-xmlrpc 2009-01-20 16:56:00 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0196.html

Note You need to log in before you can comment on or make changes to this bug.