Bug 20660 - 2.2.17-7.4 kernel and Dell GX150 i815 chipset
2.2.17-7.4 kernel and Dell GX150 i815 chipset
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 15:52 EST by Rogelio Noriega
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 19:26:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci info (4.36 KB, text/plain)
2000-11-10 16:01 EST, Dan Taylor
no flags Details
messages (33.59 KB, text/plain)
2000-11-10 16:02 EST, Dan Taylor
no flags Details

  None (edit)
Description Rogelio Noriega 2000-11-10 15:52:39 EST
2.2.17-7.4 kernel
Dell Optiplex GX150 w/ integrated i815 audio/video.
866 Mhz Intel Celeron
256 Mb ram
cdrom/floppy
on-board audio Analog Devices AD1885 AC97 Codec
on-board video 
Embedded Intel Dynamic Video Memory Technology (DVMT) 


Using the play or esdplay commands from console causes error warnings to 
standard out:

i810_audio: AC97 access failed.
i810_audio: AC97 access failed.
i810_audio: AC97 write access failed.
i810_audio: AC97 write access failed.

The messages continue until the sound finishes playing.  The sound plays 
at a faster rate than normal.  CD Audio works properly.  Quake3 video 
works fine but without sound. Attached are /var/log/messages and lspci.
Comment 1 Dan Taylor 2000-11-10 16:01:32 EST
Created attachment 5241 [details]
lspci info
Comment 2 Dan Taylor 2000-11-10 16:02:03 EST
Created attachment 5242 [details]
messages
Comment 3 Rogelio Noriega 2000-11-13 08:56:14 EST
Quake 3 Arena will not run systems locks up and has to be rebooted.
Comment 4 Rogelio Noriega 2000-11-13 15:48:18 EST
It appears that the module for i810 audio is causing the problem.

I re-installed the system using an add-on SBLive audio card, that fixed the 
esdplay errors, i810_audio: AC97 access failed, and i810_audio: AC97 write 
access failed. Quake can also be played without any problems.
Comment 5 Mick Tantasirikorn 2000-11-20 19:26:48 EST
With kernel 2.2.17-7.8 and new sndconfig and Kudzu received on 11/17 the sample 
rate error is fixed, the sound plays normally but the following error is still present.
Using the play or esdplay commands from console causes error warnings to 
standard out:

i810_audio: AC97 access failed.
i810_audio: AC97 access failed.
i810_audio: AC97 write access failed.
i810_audio: AC97 write access failed.
Comment 6 Bill Nottingham 2000-11-21 11:44:06 EST
This is fixed in 2.2.17-8.
Comment 7 Rogelio Noriega 2000-11-28 13:00:24 EST
kernel 2.2.17-8 and Dell GX150, using the play command in virtual console wav 
files play but report (sox: couldn't set to mono). esdplay works fine.

gnome, kde, mp3, audio cd all work.

quake does not run.

Note You need to log in before you can comment on or make changes to this bug.