Bug 206616 - Parsing s?maps on 64bit kernel broken
Parsing s?maps on 64bit kernel broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgtop2 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
David Lawrence
: Desktop, Reopened
: 207919 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 06:12 EDT by Bastien Nocera
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:16:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 355290 None None None Never

  None (edit)
Description Bastien Nocera 2006-09-15 06:12:43 EDT
libgtop2-2.14.1-3

The patch was already fixed upstream by Benoît Dejean:
http://bugzilla.gnome.org/show_bug.cgi?id=355290

Patch from Benoît at:
http://cvs.gnome.org/viewcvs/libgtop/sysdeps/linux/procmap.c?r1=1.22&r2=1.23

Patch will be in upstream's 2.14.4
Comment 1 Søren Sandmann Pedersen 2006-09-20 17:39:02 EDT
Fixed in rawhide, when releng moves the package.
Comment 3 Søren Sandmann Pedersen 2006-10-24 14:36:23 EDT
*** Bug 207919 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2006-10-26 16:11:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Søren Sandmann Pedersen 2006-11-15 15:10:31 EST
This was supposed to be fixed in libgtop2-2.14.4-1.fc6, where we rebased to
upstream libgtop2 2.14.4. Note: libgtop, not gnome-system-monitor. We applied
the patch that Benoit wrote upstream.

But after reading issue 102534 I see that that patch is not a complete fix, so
reopening this bug.

For reference, here is a list of issues that are related in some way to this bug:

issue 102033: "Please apply Benoit's patch", RHEL5
issue 102534: "Benoit's patch is not a complete fix", RHEL5
issue 102555: "Please apply Benoit's patch", RHEL4
issue 102659: "Benoit's patch is not a complete fix", RHEL4

The RHEL4 version is bug 210196.

Archana, if there are other IT's that are related, feel free to make a note of
them here on this bug.
Comment 9 Søren Sandmann Pedersen 2006-11-15 16:34:12 EST
Alright, I have applied the patch from
http://bugzilla.gnome.org/show_bug.cgi?id=354979 , which was also applied upstream.
Comment 10 Søren Sandmann Pedersen 2006-11-15 16:51:40 EST
So this should be fixed in gnome-system-monitor-2.16.0-3.el5.

Comment 12 RHEL Product and Program Management 2006-12-22 19:16:30 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.