Bug 206642 - Link to debuginfo packages for RHEL 3 AMD64 goes to wrong path on ftp.redhat.com
Summary: Link to debuginfo packages for RHEL 3 AMD64 goes to wrong path on ftp.redhat.com
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Vlady Zlatkin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-15 13:49 UTC by Clifford Perry
Modified: 2007-04-18 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 23:40:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Clifford Perry 2006-09-15 13:49:38 UTC
Description of problem:
When I clicked on a link [Download Debug Info Package] in 
https://rhn.redhat.com/network/software/packages/details.pxt?pid=327091, firefox
says
"550 Failed to change directory."

The link externallylink [Download Debug Info Package] points
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/x86_64/Debuginfo/kernel-debuginfo-2.4.21-37.EL.x86_64.rpm
The file and its parent directory don't exist but 

ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/AMD64/Debuginfo/kernel-debuginfo-2.4.21-37.EL.x86_64.rpm
eixts.


It seems that RHEL 4 AMD64/EM64T debuginfo RPM content is stored:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/AMD64/Debuginfo

While, RHEL 3 AMD64/EM64T/x86_64 debuginfo RPM content is stored:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/x86_64/Debuginfo

It looks like the 'dumb' logic code we use to guess and hope we are pointing in
the right location made assumption that all x86_64 packages would be found in a
x86_64 directory on ftp, while in fact, for RHEL 3, they are found in an AMD64
directory. 

As such the links found for the following RHEL 3 packages were all bad:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/x86_64/Debuginfo/4Suite-debuginfo-0.11.1-14.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/x86_64/Debuginfo/a2ps-debuginfo-4.13b-28.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/x86_64/Debuginfo/acl-debuginfo-2.2.3-1.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/3/en/os/x86_64/Debuginfo/acpid-debuginfo-1.0.2-2.x86_64.rpm

While, these links for the following RHEL 4 packages were all good:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/x86_64/Debuginfo/4Suite-debuginfo-1.0-3.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/x86_64/Debuginfo/a2ps-debuginfo-4.13b-41.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/x86_64/Debuginfo/acl-debuginfo-2.2.23-5.x86_64.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/4/en/os/x86_64/Debuginfo/acpid-debuginfo-1.0.3-2.x86_64.rpm

Version-Release number of selected component (if applicable):
RHN 412

How reproducible:
Always

Steps to Reproduce:
1. Browse within WebUI to the RHEL 3 AMD64 channel and packages associated with it. 
2. Click onto various packages and then the debuginfo link at bottom
3. Package not found, since it is looking in .../x86_64/... and not .../AMD64/..
  
Actual results:


Expected results:


Additional info:

Comment 2 Mike McCune 2006-09-28 23:40:50 UTC
not really worth fixing since we are planning on supporting real, RHN hosted,
debug-info-rpms in RHN in the near future.



Comment 3 Mike McCune 2006-10-10 19:13:35 UTC
We originally planned on adding the real support for debug-info RPMs in our
'4.2.0' release that was scheduled to be out at the end of the year but recently
found out that our priorities have shifted and this feature got dropped.  So, we
still need to determine the priority of this bug.  

I'm going to include this bug in the 5.0.0 release which is scheduled for early
January.  


Note You need to log in before you can comment on or make changes to this bug.