Bug 206652 - anaconda static IP disasters
anaconda static IP disasters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 10:53 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 23:07:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Info dumped by anaconda to floppy on crash. (77.02 KB, text/plain)
2006-09-15 10:53 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2006-09-15 10:53:01 EDT
Description of problem:

Loads of problems with configuring a static IP address.

1. When I click the Edit button to change to a static config, the dialog
box I get has two fields separated by a /. I have no idea what that might
actually mean, but I'm guessing a netmask goes in the 2nd field. A label
would be nice.

2. I don't know IPv6 from a dead crab. I have no idea what to put in an
IPv6 address field, so I click the toggle to disable IPv6. Even with that
toggle turned off, the dialog box won't let me click on Next because it
says I didn't fill in the IPv6 address (duh :-).

3. I go ahead and enable IPv6 figuring it will tell me when I manage to
type some gibberish that makes it happy. The first gibberish I try is 1.2.3
when then results in an anaconda crash (I'll attach the info I had it save
to a floppy).

So, basically I can't install because I can't get past the network setup.
I guess I'll try again and lie to it, telling it to use DHCP then see if I
can config the network interface to be static after I get installed.

This may be the same as bug 206588, but I had enough extra problems I
figured I should submit a new bug.

Version-Release number of selected component (if applicable):

Whatever came on the fc6t3 DVD for x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. try to setup static IP when installing
2.
3.
  
Actual results:

Problems described above

Expected results:

A nice static IP.

Additional info:
Comment 1 Tom Horsley 2006-09-15 10:53:01 EDT
Created attachment 136366 [details]
Info dumped by anaconda to floppy on crash.
Comment 2 Glenn Simpson 2006-09-15 11:52:29 EDT
I had the same problem on an I386-32bit host (AMD 2000+) on a desktop machine
As a temporary work around, I used DHCP but that is not a satisfactory result
for me.  I need to be able to use a static address and currently have no need
for a ipv6 method.
Comment 3 Justin Farrelly 2006-09-16 14:04:59 EDT
Similar problems - seems anything I do in assigning a static address causes
anaconda to crash (64 bit install from DVD). Had to go the default route to get
anywhere. Some on screen hints at this point would be good along with error
checking.....
Comment 4 David Cantrell 2006-09-18 23:07:50 EDT
(In reply to comment #0)
> 1. When I click the Edit button to change to a static config, the dialog
> box I get has two fields separated by a /. I have no idea what that might
> actually mean, but I'm guessing a netmask goes in the 2nd field. A label
> would be nice.

I've added labels to the stage2 configuration screen.  I have not added labels
in the loader code yet.  Both the manual IP configuration in the loader (stage1,
text mode portion) and in stage2 (the stuff that runs after we say Running
anaconda...) accept values according to these rules:

For IPv4, the first field is the IP address.  You must enter the address in
dotted-quad notation.  The field after the / is the netmask.  For IPv4, you can
enter the tradition dotted-quad netmask or you can enter a CIDR-style prefix
value (between 0 and 32).  The following are valid examples:

192.168.1.1/24
192.168.1.1/255.255.255.0

For IPv6, the first field is the IP address.  You must enter the address in
hex-colon notation (if that's the proper name).  The field after the / is the
prefix.  The only acceptable values for an IPv6 prefix are integers between 0
and 128, inclusive.

> 2. I don't know IPv6 from a dead crab. I have no idea what to put in an
> IPv6 address field, so I click the toggle to disable IPv6. Even with that
> toggle turned off, the dialog box won't let me click on Next because it
> says I didn't fill in the IPv6 address (duh :-).

This is an input validation bug that slipped in to FC6 Test 3.  My apologies.  I
have corrected the problem and the fixes will be included in the next build of
anaconda in to rawhide.

> 3. I go ahead and enable IPv6 figuring it will tell me when I manage to
> type some gibberish that makes it happy. The first gibberish I try is 1.2.3
> when then results in an anaconda crash (I'll attach the info I had it save
> to a floppy).

Interesting to note.  It's probably trying to validate it as an IPv4 address,
but not realizing it's too short.  I check for periods and then pass to
inet_ntop() for validation.  I'll fix this up, though you shouldn't see it
anymore with the correct input validation in place.

> So, basically I can't install because I can't get past the network setup.
> I guess I'll try again and lie to it, telling it to use DHCP then see if I
> can config the network interface to be static after I get installed.

It's not really the end of the world.  Proceed with the install by selecting
DHCP.  After it installs packages and asks you to Reboot, don't.  Instead, go
over to tty2 and change to /mnt/sysimage/etc/sysconfig/network-scripts.  Edit
the ifcfg-ethX script for your network interface and set it up using your static
IP configuration.  Once you are done, go back to tty6 (Alt+F6) and click Reboot.

Note You need to log in before you can comment on or make changes to this bug.