Bug 206696 - initscripts activate ONBOOT=no ethernet aliases (!)
initscripts activate ONBOOT=no ethernet aliases (!)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
http://www.citycarshare.org/
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 15:15 EDT by Bryce Nesbitt
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 16:05:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Nesbitt 2006-09-15 15:15:29 EDT
I have a primary eth0, and eight alaises (eth0:0-eth0:7).

If I set ONBOOT=no for the aliases, it is INCORECTLY brought up on reboot.

[root@14252-24879 network-scripts]# cat ifcfg-eth0
# Intel Corporation 82541GI/PI Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=static
ONBOOT=yes
IPADDR=216.93.188.133
NETMASK=255.255.255.240
GATEWAY=216.93.188.129

[root@14252-24879 network-scripts]# cat ifcfg-eth0:1
# Intel Corporation 82541GI/PI Gigabit Ethernet Controller
DEVICE=eth0:1
BOOTPROTO=static
ONBOOT=no
IPADDR=216.93.188.135
NETMASK=255.255.255.240
[root@14252-24879 network-scripts]# cat ifcfg-eth0:6

# Intel Corporation 82541GI/PI Gigabit Ethernet Controller
#DEVICE=eth0:6
#BOOTPROTO=static
#ONBOOT=no
#IPADDR=216.93.188.140
#NETMASK=255.255.255.240
[root@14252-24879 network-scripts]#


After boot I see:


[root@14252-24879 network-scripts]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.133  Bcast:216.93.188.143  Mask:255.255.255.240
          inet6 addr: fe80::230:48ff:fe70:3a06/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:378 errors:0 dropped:0 overruns:0 frame:0
          TX packets:221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:39237 (38.3 KiB)  TX bytes:33943 (33.1 KiB)
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:0    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.134  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:1    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.135  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:2    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.136  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:3    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.137  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:4    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.138  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:5    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.139  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

eth0:7    Link encap:Ethernet  HWaddr 00:30:48:70:3A:06
          inet addr:216.93.188.141  Bcast:216.93.188.143  Mask:255.255.255.240
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Base address:0xc400 Memory:fd8c0000-fd8e0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:678 (678.0 b)  TX bytes:678 (678.0 b)
Comment 1 Bryce Nesbitt 2006-09-15 15:21:12 EDT
Marking as priority HIGH, because IP address conflicts can take down critical
services (the mess can get really big really quick).

Note:

Manually running ./ifup eth0:5 boot
does the right thing.  And the initscript looks fine too.

But rebooting is the acid test, and that's simply not working as expected.  I'm
not sure the exact code path.
Comment 2 Bryce Nesbitt 2006-09-15 15:21:39 EDT
I'm hoping for a patch to fc5, available via yum...
Comment 3 Bill Nottingham 2006-09-15 15:32:51 EDT
ONBOOT is not a valid option for aliases - you want ONPARENT.
Comment 4 Bryce Nesbitt 2006-09-15 15:59:39 EDT
Then convert it to a suggestion:
   ONBOOT=no
Is more orthoganal, and easier for sysadmins to grasp.


Where is ONPARENT documented?
    man ifup
Did not work.

# This script goes out of its way to arrive at the configuration of ip
# aliases described in the ifcfg-$DEV:* and ifcfg-$DEV-range* files from
# whatever existing configuration it may be given:.
Comment 5 Bill Nottingham 2006-09-15 16:05:11 EDT
It's documented in sysconfig.txt.
Comment 6 Bryce Nesbitt 2006-09-15 16:34:27 EDT
ok, found it, thank you.

Note You need to log in before you can comment on or make changes to this bug.