Bug 206712 - NFS-Server has mutex problems
NFS-Server has mutex problems
Status: CLOSED DUPLICATE of bug 199936
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-15 16:27 EDT by mail@romal.de
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 23:07:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mail@romal.de 2006-09-15 16:27:35 EDT
Description of problem:

nfs-server complains about mutex problems.

from /var/log/messages

Sep 15 17:59:35 niep mountd[1869]: Fake hostname noname for 192.168.1.101 -
forward lookup doesn't exist
Sep 15 17:59:35 niep mountd[1869]: authenticated mount request from
192.168.1.101:1016 for /home/romal (/home/romal)
Sep 15 18:02:15 niep kernel: 
Sep 15 18:02:15 niep kernel: =============================================
Sep 15 18:02:15 niep kernel: [ INFO: possible recursive locking detected ]
Sep 15 18:02:15 niep kernel: ---------------------------------------------
Sep 15 18:02:15 niep kernel: nfsd/1863 is trying to acquire lock:
Sep 15 18:02:15 niep kernel:  (&inode->i_mutex){--..}, at: [<c0611368>]
mutex_lock+0x21/0x24
Sep 15 18:02:15 niep kernel: 
Sep 15 18:02:15 niep kernel: but task is already holding lock:
Sep 15 18:02:15 niep kernel:  (&inode->i_mutex){--..}, at: [<c0611368>]
mutex_lock+0x21/0x24
Sep 15 18:02:15 niep kernel: 
Sep 15 18:02:15 niep kernel: other info that might help us debug this:
Sep 15 18:02:15 niep kernel: 2 locks held by nfsd/1863:
Sep 15 18:02:15 niep kernel:  #0:  (hash_sem){..--}, at: [<f0c044fa>]
exp_readlock+0xd/0xf [nfsd]
Sep 15 18:02:16 niep kernel:  #1:  (&inode->i_mutex){--..}, at: [<c0611368>]
mutex_lock+0x21/0x24
Sep 15 18:02:16 niep kernel: 
Sep 15 18:02:16 niep kernel: stack backtrace:
Sep 15 18:02:16 niep kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x159
Sep 15 18:02:16 niep kernel:  [<c04057ea>] show_trace+0xd/0x10
Sep 15 18:02:16 niep kernel:  [<c0405903>] dump_stack+0x19/0x1b
Sep 15 18:02:16 niep kernel:  [<c043b9c0>] __lock_acquire+0x773/0x997
Sep 15 18:02:16 niep kernel:  [<c043c155>] lock_acquire+0x4b/0x6a
Sep 15 18:02:16 niep kernel:  [<c06111f9>] __mutex_lock_slowpath+0xbc/0x20a
Sep 15 18:02:16 niep kernel:  [<c0611368>] mutex_lock+0x21/0x24
Sep 15 18:02:16 niep kernel:  [<c047fd1c>] vfs_unlink+0x73/0xe3
Sep 15 18:02:16 niep kernel:  [<f0c0109a>] nfsd_unlink+0x18f/0x1e2 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0c081e0>] nfsd3_proc_remove+0x95/0xa2 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0bfe0d4>] nfsd_dispatch+0xc0/0x178 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0b797cb>] svc_process+0x3a4/0x5ee [sunrpc]
Sep 15 18:02:16 niep kernel:  [<f0bfe5f6>] nfsd+0x197/0x2e1 [nfsd]
Sep 15 18:02:16 niep kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Sep 15 18:02:16 niep kernel: DWARF2 unwinder stuck at kernel_thread_helper+0x5/0xb
Sep 15 18:02:16 niep kernel: Leftover inexact backtrace:
Sep 15 18:02:16 niep kernel:  [<c04057ea>] show_trace+0xd/0x10
Sep 15 18:02:16 niep kernel:  [<c0405903>] dump_stack+0x19/0x1b
Sep 15 18:02:16 niep kernel:  [<c043b9c0>] __lock_acquire+0x773/0x997
Sep 15 18:02:16 niep kernel:  [<c043c155>] lock_acquire+0x4b/0x6a
Sep 15 18:02:16 niep kernel:  [<c06111f9>] __mutex_lock_slowpath+0xbc/0x20a
Sep 15 18:02:16 niep kernel:  [<c0611368>] mutex_lock+0x21/0x24
Sep 15 18:02:16 niep kernel:  [<c047fd1c>] vfs_unlink+0x73/0xe3
Sep 15 18:02:16 niep kernel:  [<f0c0109a>] nfsd_unlink+0x18f/0x1e2 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0c081e0>] nfsd3_proc_remove+0x95/0xa2 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0bfe0d4>] nfsd_dispatch+0xc0/0x178 [nfsd]
Sep 15 18:02:16 niep kernel:  [<f0b797cb>] svc_process+0x3a4/0x5ee [sunrpc]
Sep 15 18:02:16 niep kernel:  [<f0bfe5f6>] nfsd+0x197/0x2e1 [nfsd]
Sep 15 18:02:16 niep kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Sep 15 18:19:23 niep mountd[1869]: Fake hostname noname for 192.168.1.101 -
forward lookup doesn't exist
Sep 15 18:19:23 niep mountd[1869]: authenticated unmount request from
192.168.1.101:1014 for /home/romal (/home/romal)


Version-Release number of selected component (if applicable):


How reproducible:

happens multiple times every day.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Did not happen on RHEL4U3. The system was updated to RHEL5B1 and the problem
showed up.
Comment 1 Jay Turner 2006-09-20 23:07:57 EDT
This issue is a result of some new lock detection code we enabled in the RHEL5
betas.

*** This bug has been marked as a duplicate of 199936 ***

Note You need to log in before you can comment on or make changes to this bug.