Bug 20673 - AC97 sound card badly recognized ?
AC97 sound card badly recognized ?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-11 04:50 EST by Need Real Name
Modified: 2007-03-26 23:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-05 09:21:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-11 04:50:10 EST
I have upgraded my RedHat Linux 6.2fr to 7.0.
The AC97 sound card seems recognized, but does not make sound correctly 
(strange sounds, CD-Rom not playing audio CDs...).
My computer is a Packard Bell "Club 2500c", including a SigmaTel card.

****** I do not know the component name *****
Comment 1 Michael Fulbright 2000-11-13 14:29:47 EST
Reassigning to kudzu.
Comment 2 Bill Nottingham 2000-11-13 14:43:14 EST
What does 'lspci' say, and what does your /etc/modules.conf look like?
Comment 3 Need Real Name 2000-11-14 14:48:31 EST
Here is the result of lspci
===========================
00:00.0 Host bridge: Intel Corporation 82810 GMCH [Graphics Memory Controller 
Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810 CGC [Chipset 
Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 
02)
00:1f.6 Modem: Intel Corporation 82801AA AC'97 Modem (rev 02)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)

Here is the /etc/modules.conf file
==================================
alias eth0 rtl8139 
alias parport_lowlevel parport_pc 
alias sound-slot-0 i810_audio 
alias usb-controller usb-uhci 

And here is the /proc/pci file
==============================
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel Unknown device (rev 3).
      Vendor id=8086. Device id=7120.
      Fast devsel.  Fast back-to-back capable.  Master Capable.  No bursts.  
  Bus  0, device   1, function  0:
    VGA compatible controller: Intel Unknown device (rev 3).
      Vendor id=8086. Device id=7121.
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master Capable.  No 
bursts.  
      Prefetchable 32 bit memory at 0xe8000000 [0xe8000008].
      Non-prefetchable 32 bit memory at 0xeff80000 [0xeff80000].
  Bus  0, device  30, function  0:
    PCI bridge: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2418.
      Fast devsel.  Fast back-to-back capable.  Master Capable.  No bursts.  
  Bus  0, device  31, function  0:
    ISA bridge: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2410.
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.  
  Bus  0, device  31, function  1:
    IDE interface: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2411.
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.  
      I/O at 0xff00 [0xff01].
  Bus  0, device  31, function  2:
    USB Controller: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2412.
      Medium devsel.  Fast back-to-back capable.  IRQ 9.  Master Capable.  No 
bursts.  
      I/O at 0xd600 [0xd601].
  Bus  0, device  31, function  3:
    SM Bus: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2413.
      Medium devsel.  Fast back-to-back capable.  
      I/O at 0x4c0 [0x4c1].
  Bus  0, device  31, function  5:
    Multimedia audio controller: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2415.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  No 
bursts.  
      I/O at 0xda00 [0xda01].
      I/O at 0xd800 [0xd801].
  Bus  0, device  31, function  6:
    Unknown class: Intel Unknown device (rev 2).
      Vendor id=8086. Device id=2416.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  No 
bursts.  
      I/O at 0xde00 [0xde01].
      I/O at 0xdc00 [0xdc01].
  Bus  1, device   5, function  0:
    Ethernet controller: Realtek 8139 (rev 16).
      Medium devsel.  Fast back-to-back capable.  IRQ 3.  Master Capable.  
Latency=64.  Min Gnt=32.Max Lat=64.
      I/O at 0xbc00 [0xbc01].
      Non-prefetchable 32 bit memory at 0xefdfff00 [0xefdfff00].

Thanks for everything and good work.
Comment 4 Bill Nottingham 2000-11-15 11:43:45 EST
OK, you're using the i810_audio driver. This is a kernel issue.
Comment 5 Need Real Name 2001-01-28 13:09:09 EST
Today, the card is OK with the CD reader. I do not know why. I will give you 
more details when available.
Comment 6 johnlar 2001-02-06 18:32:26 EST
I am having this problem also, with a new Gateway Professional V700Cse it has integrated i810 sound. Something of interesting to note, in 7.0 I got no 
sound at all while in fisher I can get sound when X in not running using "play sound.wav" it gives some errors but plays, when I run startx with sound card 
configured it throws DMA overrun errors into every tty.
Comment 7 johnlar 2001-02-07 01:46:09 EST
Doing more investigation, actually it does seem to work sorta sometimes its 
very strange. in 7.1 when you run sndconfig the first time you hear no sound, 
if you tell it that you did hear the sound then run it again accepting the 
normal defaults you will hear the test sound played very fast and quietly. (or 
is it supposed to play fast? I'm not sure) anyhow I can now use play sound.wav 
but I have to turn the speakers all the way up and use -v 9 switch to get much 
sound out of it. It gives the errors
sox: Sound card appears to only support singled word samples.  Overriding 
formatsox: 
Couldn't set to mono
DMA overrun on send

BTW that last error is the error I contantly get when I run KDE, found it it 
seems to no give the errors on GNOME though it still does not play sound.

Most importantly! if I switch XMMS from eSound Output Plugin to OSS Driver it 
will play sound just fine, then if I switch it back to eSound it will continue 
to play sound fine!  but nothing else of the system will play sound.

Am I am typing this I tryed restarting the aRts soundserver which seemed to 
have quit shortly after kde started it made the speakers crackle and respit 
out a bunch of DMA overrun on send  errors and XMMS would not work, untill I 
stopped the server. (started and stopped the server by selecting and 
unselecting "Start aRts soundserver at startup" from Control Center and 
applying changes.)
So it seems to be a multi layered problem :) good luck -grin-
Comment 8 Yaron Minsky 2001-03-01 17:15:11 EST
I'm running RH7.0 on a Dell Optiplex GX110, and have also been having sound
problems.  The machine has i810 sound as well.  It sometimes works, but
sometimes just cuts out.  For instance, when trying to start esd, you sometimes
get the message

      /dev/dsp: No such device

at which point, nothing will generate sound until I reboot.

I'm not sure what causes the problem, but one definite source is trying to play
one of the Loki Demos.  That tends to kill the sound pretty quick.  But it also
happens without running the Loki demos.

Sounds like the i810 drivers are pretty broken.
Comment 9 Need Real Name 2001-03-03 09:13:26 EST
After some tests... The CD-Rom works correctly in direct connection (audio 
signal via wires, no data through the CPU). The MP3 player works, too, but I 
often have the problem of strange noises, the counter increases number of 
seconds more than the real time (most often at the beginning of the music or 
when switching from a task to another one): Often, the music start at seonc #10 
or 20, instead of 0 ! Results seem better with FreeAmp (www.freeamp.org) than 
with XMMS.
Everything is like... "i810 is a cheap chipset and a poor device", but I think 
there are a few bugs living in the driver. Good hunt and thanks for your job.
Comment 10 Jimmy Rimmer 2001-12-04 22:29:49 EST
I'm running RedHat 7.2 and I have a very similar issue to what johnlar@tfn.net 
described above.

I'm running a machine with the Asus A7V, which uses the Via 686 and has AC97 
sound.

On boot, sound doesn't work.  In order to get sound, I have to run sndconfig.  
It asks if I heard the sound play.  I didn't, but if I say, "Yes," the sound 
works.  My kernel revision is 2.4.7-10.

Good luck with this one. :)
Comment 11 Need Real Name 2001-12-05 09:21:26 EST
I am now running RedHat 7.1 and it works correctly. For me, the bug can be 
closed. To be checked with other members.

Note You need to log in before you can comment on or make changes to this bug.