Bug 206756 - 2.6.17-1.2647.fc6 - raw1394 driver appears blocked by SELinux
2.6.17-1.2647.fc6 - raw1394 driver appears blocked by SELinux
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 03:56 EDT by Miles Lane
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miles Lane 2006-09-16 03:56:18 EDT
Description of problem:

audit(1158392665.818:4): avc:  denied  { getattr } for  pid=1195
comm="pam_console_app" name="raw1394" dev=tmpfs ino=4896
scontext=system_u:system_r:pam_console_t:s0-s0:c0.c255
tcontext=system_u:object_r:device_t:s0 tclass=chr_file

Version-Release number of selected component (if applicable):

2.6.17-1.2647.fc6

How reproducible:
Always

Steps to Reproduce:
1.Boot with my videocam attached to my firewire port.
Comment 1 Daniel Walsh 2006-09-18 11:23:07 EDT
Fixed in selinux-policy-2.3.14-4
Comment 2 Jerry James 2006-11-13 18:23:55 EST
I'm seeing what appears to be the same problem on an i386 FC6 box.  I am running
kernel-2.6.18-1.2849.fc6, and have selinux-policy-2.4.3-2.fc6 installed.  The
logs show messages like this:

audit(1163457157.604:5): avc:  denied  { getattr } for  pid=1700 comm="pam_conso
le_app" name="raw1394" dev=tmpfs ino=6646 scontext=system_u:system_r:pam_console
_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
audit(1163457157.604:6): avc:  denied  { setattr } for  pid=1700 comm="pam_conso
le_app" name="raw1394" dev=tmpfs ino=6646 scontext=system_u:system_r:pam_console
_t:s0 tcontext=system_u:object_r:device_t:s0 tclass=chr_file
Comment 3 Daniel Walsh 2006-11-13 23:19:57 EST
Looks like a bug in the file context.

You can fix for now by executing

semanage fcontext -a -t v4l_device_t /dev/raw1394

I will fix this in next weeks update.

Fixed in selinux-policy-2.4.3-12
Comment 4 Daniel Walsh 2007-08-22 10:16:57 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.