Bug 206772 - Sshd services shutdown does'nt work
Sshd services shutdown does'nt work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 09:11 EDT by Pti-seb
Modified: 2014-03-16 23:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 19:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
secure file log (25.56 KB, application/octet-stream)
2006-09-16 09:17 EDT, Pti-seb
no flags Details
/var/log/messages (294.75 KB, text/plain)
2006-09-17 13:18 EDT, Pti-seb
no flags Details
Dmesg output after fails (55.14 KB, text/plain)
2006-09-19 06:47 EDT, Pti-seb
no flags Details

  None (edit)
Description Pti-seb 2006-09-16 09:11:29 EDT
Description of problem:
Sshd services shutdown does'nt work

How reproducible:
Everytimes

Steps to Reproduce:
1. open root terminal
2. launch /etc/init.d/sshd start
3. launch /etc/init.d/sshd stop
  
Actual results:
Stopping sshd failed

Additional info:
[root@localhost ~]# /etc/init.d/sshd stop
Stopping sshd:                                             [FAILED]
[root@localhost ~]# /etc/init.d/sshd start
Starting sshd:                                             [  OK  ]
[root@localhost ~]# /etc/init.d/sshd stop
Stopping sshd:                                             [FAILED]
[root@localhost ~]#
Comment 1 Pti-seb 2006-09-16 09:17:46 EDT
Created attachment 136427 [details]
secure file log
Comment 2 Pti-seb 2006-09-17 13:15:50 EDT
I have the same prolbem with atd, cups and crond initscript :

[root@localhost ~]# /etc/init.d/atd stop
Stopping atd:                                              [FAILED]
[root@localhost ~]# /etc/init.d/atd start
Starting atd:                                              [  OK  ]
[root@localhost ~]# /etc/init.d/atd stop
Stopping atd:                                              [FAILED]
[root@localhost ~]# /etc/init.d/cups stop
Stopping cups:                                             [FAILED]
[root@localhost ~]# /etc/init.d/cups start
Starting cups:                                             [  OK  ]
[root@localhost ~]# /etc/init.d/cups stop
Stopping cups:                                             [FAILED]
[root@localhost ~]# /etc/init.d/crond stop
Stopping crond:                                            [FAILED]
[root@localhost ~]# /etc/init.d/crond start
Starting crond:                                            [  OK  ]
[root@localhost ~]# /etc/init.d/crond stop
Stopping crond:                                            [FAILED]
Comment 3 Pti-seb 2006-09-17 13:18:12 EDT
Created attachment 136489 [details]
/var/log/messages
Comment 4 Pti-seb 2006-09-17 13:19:28 EDT
I have these bugs since I updated my fc6test3 with yum update command.
Comment 5 Bill Nottingham 2006-09-18 13:30:59 EDT
Any AVC messages?
Comment 6 Pti-seb 2006-09-18 17:04:28 EDT
Sorry, but I don't understand "AVC messages" ...
Comment 7 Bill Nottingham 2006-09-18 21:46:38 EDT
Can you attach the output of 'dmesg' after it fails?
Comment 8 Pti-seb 2006-09-19 06:47:31 EDT
Created attachment 136623 [details]
Dmesg output after fails
Comment 9 Bill Nottingham 2006-09-19 10:56:39 EDT
CC'ing SELinux maintainer - I don't *think* those errors are relevant to this
problem, but I'm not 100% sure.
Comment 10 Daniel Walsh 2006-09-19 11:11:59 EDT
Does not look like an SELinux problem.
Comment 11 Stefan Becker 2006-09-20 11:35:46 EDT
I think it is a SELinux problem:

# service sshd status
sshd dead but pid file exists
# service atd status
atd dead but pid file exists
# service crond status
crond dead but pid file exists

# setenforce 0
# service sshd status
sshd (pid 1779) is running...
# service atd status
atd (pid 1863) is running...
# service crond status
crond (pid 1815) is running...

SELinux hides processes, even from root, which can come to a surprise when you
run top and but none of the processes is eating those CPU cycles! 
Comment 12 Daniel Walsh 2006-09-20 12:50:17 EDT
Fixed in selinux-policy-2.3.14-4
Comment 13 Pti-seb 2006-10-09 17:28:12 EDT
Ok, you can close now. It's work for me.

Note You need to log in before you can comment on or make changes to this bug.