This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 206773 - Yelp dependency problem : libgtkembedmoz.so not found.
Yelp dependency problem : libgtkembedmoz.so not found.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 207041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 09:55 EDT by Han-Wen Nienhuys
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 08:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Han-Wen Nienhuys 2006-09-16 09:55:47 EDT
[hanwen@haring nobackup]$ yelp
yelp: error while loading shared libraries: libgtkembedmoz.so: cannot open
shared object file: No such file or directory

[hanwen@haring nobackup]$ rpm -q yelp
yelp-2.16.0-2.fc6

(also, it seems that libgtkmozembed is duplicated among several mozilla / gecko
apps, but I assume that that is intentional)
Comment 1 Matthew Barnes 2006-09-18 17:04:17 EDT
Thanks for the bug report.

Hmm, yelp-2.16.0-2.fc6 starts up successfully for me.

Can I ask what version of firefox you have installed?
Comment 2 Joshua Wulf 2006-09-19 03:04:15 EDT
I have yelp-2.16.0-2.fc6 and firefox-1.5.0.7-1.fc6 and I get this same issue - I
just noticed it today, so it has happened sometime in the last week.

[jwulf@localhost en-US]$ yelp
yelp: error while loading shared libraries: libgtkembedmoz.so: cannot open
shared object file: No such file or directory

ldd $(which yelp)|grep found
        libgtkembedmoz.so => not found
        libxpcom.so => not found
        libxpcom_core.so => not found

[jwulf@localhost en-US]$ locate libgtkembedmoz.so
/usr/lib/firefox-1.5.0.7/libgtkembedmoz.so

[jwulf@localhost en-US]$ export LD_LIBRARY_PATH=/usr/lib/firefox-1.5.0.7/
[jwulf@localhost en-US]$ yelp

Yelp-ERROR **: Could not initialize gecko!
aborting...

My machine is tracking rawhide daily.
Comment 3 Han-Wen Nienhuys 2006-09-19 08:39:46 EDT
I have the same setup as Joshua. 
Comment 4 Han-Wen Nienhuys 2006-09-19 08:59:49 EDT
thanks! working with yelp-2.16.0-3.fc6 now
Comment 5 Matthew Barnes 2006-09-19 12:02:13 EDT
*** Bug 207041 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.