Bug 206776 - Tsclient applet crashes
Summary: Tsclient applet crashes
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tsclient (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-16 15:01 UTC by George Billios
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 14:14:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Billios 2006-09-16 15:01:44 UTC
Description of problem:
If you add Terminal Server Client applet to gnome-panel it always presents the
following dialog:

"The panel encountered a problem while loading "OAFIID:GNOME_TSClientApplet". Do
you want to delete the applet from your configuration?"  

with no other info

Version-Release number of selected component (if applicable):
tsclient-0.148-2.1
gnome-applets-2.16.0.1-3.fc6
gnome-panel-2.16.0-1.fc6

How reproducible:


Steps to Reproduce:
1.Open 'Add to Panel' dialog
2.Select 'Terminal Server Client'
3.Click 'Add'
  
Actual results:
Dialog box:
"The panel encountered a problem while loading "OAFIID:GNOME_TSClientApplet". Do
you want to delete the applet from your configuration?"  

Expected results:
To add the applet

Additional info:

Used to work in FC5

Comment 1 Matthias Clasen 2006-09-20 14:14:26 UTC
Turns out the applet we shipped was just an empty shell. 
I tried building the real applet, but it has bugs that can kill your desktop.
Therefore I have removed the applet for now.

Comment 2 Ricardo Cerqueira 2006-10-24 16:23:31 UTC
Hm, I rebuilt the package after regenerating configure (with autogen.sh) and the
applet has been pretty solid for the last couple of days...

Comment 3 Dax Kelson 2006-11-03 19:41:52 UTC
(In reply to comment #1)
> Turns out the applet we shipped was just an empty shell. 
> I tried building the real applet, but it has bugs that can kill your desktop.
> Therefore I have removed the applet for now.

What are the "kill your desktop" bugs? I really miss the applet in FC6. It
worked flawlessly for me in FC3/FC4/FC5.

Comment 4 Manmathan Kumarathurai 2006-11-06 14:41:39 UTC
(In reply to comment #2)
> Hm, I rebuilt the package after regenerating configure (with autogen.sh) and the
> applet has been pretty solid for the last couple of days...

Could you please specify how to this?


Comment 5 Dax Kelson 2006-11-06 17:27:42 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Hm, I rebuilt the package after regenerating configure (with autogen.sh) and the
> > applet has been pretty solid for the last couple of days...
> 
> Could you please specify how to this?
> 

Install the SRPM and modify %build section of the spec file with:


%build

./autogen.sh <----- This is the addition you make
%configure
make %{?_smp_mflags}

Matthias, I note you have it fixed in rawhide now. Can you push out an official
FC6 errata?

Comment 6 Manmathan Kumarathurai 2006-11-07 13:51:46 UTC
(In reply to comment #5)
> %build
> 
> ./autogen.sh <----- This is the addition you make
> %configure
> make %{?_smp_mflags}

Thanks for the hint, but I found out that more corrections needed to get the
applet installed, since it is explicitly removed.

In short: I added following line instead of the 3 lines beginning with "# don't
include the applet, since it does not work"

perl -pi -e 's/Client Applet/Client/g' $RPM_BUILD_ROOT%{_libdir}/bonobo/servers
/*.server

I am not sure if this is needed.

Then I added two more lines after "%{_bindir}/*":
%{_libexecdir}/*
%{_libdir}/bonobo/servers/*

Thanks to you, I am now enjoying the applet shortcut ;-)

> Matthias, I note you have it fixed in rawhide now. Can you push out an official
> FC6 errata?

Would be very nice if a corrected version is pushed into FC6.



Note You need to log in before you can comment on or make changes to this bug.