Bug 206794 - OpenOffice.org Impress crashes trying to display a slideshow
OpenOffice.org Impress crashes trying to display a slideshow
Status: CLOSED DUPLICATE of bug 205848
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 15:17 EDT by Bryan Christ
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 04:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Christ 2006-09-16 15:17:50 EDT
Description of problem:

OpenOffice.org Impress crashes trying to display a slideshow.  This happens with
both odp and ppt files.

Version-Release number of selected component (if applicable):

Runing Fedora Core 6 test 2 with the latest updates via yum as of Sept 16, 2006.

[root@kricket ~]# rpm -qa |grep -i -e 'openoffice'
openoffice.org-xsltfilter-2.0.4-3.1
openoffice.org-impress-2.0.4-3.1
openoffice.org-core-2.0.4-3.1
openoffice.org-draw-2.0.4-3.1
openoffice.org-math-2.0.4-3.1
openoffice.org-calc-2.0.4-3.1
openoffice.org-writer-2.0.4-3.1
openoffice.org-graphicfilter-2.0.4-3.1


How reproducible:

Every time.

Steps to Reproduce:
1.  Open a presentation
2.  Try to display slideshow

3.
  
Actual results:

OpenOffice.org crashes

Expected results:

Display slideshow

Additional info:

(I)    x.org loaded video driver of...
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-20-i386
(V)    kernel is: Linux 2.6.17-1.2647.fc6 #1 SMP Wed Sep 13 12:51:50 EDT 2006
i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-3.1-i386
(VII)  accessibility is: false
(VIII) fedora release is: Fedora Core release 5.92 (FC6 Test3)
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0xb7f01000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x009bc000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x007a9000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00fe3000)
	libdl.so.2 => /lib/libdl.so.2 (0x0085c000)
	libpthread.so.0 => /lib/libpthread.so.0 (0x00111000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so
(0x00b86000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00c68000)
	libm.so.6 => /lib/libm.so.6 (0x004c6000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00e4c000)
	libc.so.6 => /lib/libc.so.6 (0x00128000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00265000)
	/lib/ld-linux.so.2 (0x00368000)
...end sample ldd details ...
0x65492cc: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x202cc
0x6549b01: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x20b01
0xb7ffe420:  + 0x420 (__kernel_sigreturn + 0x0)
0xe228b7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x208b7
0xe264c3: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x244c3
(_ZN14X11SalGraphics4InitEP19X11SalVirtualDeviceP11SalColormapb + 0xe1)
0xe267fd: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x247fd
0xe267cb: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x247cb
(_ZN14X11SalInstance19CreateVirtualDeviceEP11SalGraphicslltPK18SystemGraphicsData
+ 0xe5)
0x6c9a00f: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11f00f
0x6c9a25d: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x11f25d
(_ZN13VirtualDeviceC1EPK18SystemGraphicsDatat + 0x4f)
0x4832d19: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x20d19
0x48337c4: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x217c4
0x4829cde: /usr/lib/openoffice.org2.0/program/cairocanvas.uno.so + 0x17cde
0x31b1edb: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x30edb
0x31afa1e: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x2ea1e
0x31b19a5: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x309a5
0x31a40fc: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x230fc
0x31a42bf: /usr/lib/openoffice.org2.0/program/libcppcanvas680li.so + 0x232bf
(_ZNK9cppcanvas8internal12ImplRenderer4drawEv + 0x4f)
0x368cb1c: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc7b1c
0x368da00: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc8a00
0x368db23: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xc8b23
0x363e77f: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x7977f
0x3656ac3: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91ac3
0x3656af8: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91af8
0x3656bcd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91bcd
0x3656c02: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91c02
0x3657017: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x92017
0x3656264: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x91264
0x365814e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9314e
0x3672339: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xad339
0x36730bd: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0xae0bd
0x35ff88f: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3a88f
0x35ff93e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3a93e
0x35ffdbe: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3adbe
0x361501e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x5001e
0x3603a0a: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x3ea0a
0x361eff9: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x59ff9
0x363061b: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x6b61b
0x365fd7e: /usr/lib/openoffice.org2.0/program/slideshow.uno.so + 0x9ad7e
0x2fe3fba: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2f1fba
0x2fe40d6: /usr/lib/openoffice.org2.0/program/libsd680li.so + 0x2f20d6
0x6c06e50: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8be50
0x6c138ec: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x988ec
(_ZN5Timer7TimeoutEv + 0x1c)
0x6c13a2a: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x98a2a
(_ZN5Timer21ImplTimerCallbackProcEv + 0x78)
0xe40473: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e473
0xe402ac: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x3e2ac
(_ZNK10X11SalData7TimeoutEv + 0x24)
0xf60527: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x13527
0xf6054b: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1354b
0x5b51916: /lib/libglib-2.0.so.0 + 0x2b916
0x5b51342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x5b5431f: /lib/libglib-2.0.so.0 + 0x2e31f
0x5b54885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0xf6022a: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x1322a
0xe47a9e: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45a9e
(_ZN14X11SalInstance5YieldEbb + 0x2c)
0x6c0f473: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94473
(_ZN11Application5YieldEb + 0x53)
0x6c0f508: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x94508
(_ZN11Application7ExecuteEv + 0x28)
0x2c7d186: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x24186
(_ZN7desktop7Desktop4MainEv + 0x164e)
0x6c132de: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x982de
0x6c133d3: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x983d3
(_Z6SVMainv + 0x2b)
0x2c76d09: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd09 (sal_main
+ 0x5d)
0x2c76d55: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x1dd55 (main + 0x27)
0x116f2c: /lib/libc.so.6 + 0x15f2c (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/simpress.bin + 0x4a1
Comment 1 Caolan McNamara 2006-09-18 04:42:42 EDT
Can you attach a presentation which causes this to happen ?

*** This bug has been marked as a duplicate of 205848 ***

Note You need to log in before you can comment on or make changes to this bug.