Bug 206828 - unable to setup kernel sources
unable to setup kernel sources
Status: CLOSED DUPLICATE of bug 199175
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-16 20:49 EDT by Tom Horsley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 05:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-09-16 20:49:17 EDT
Description of problem:

I don't actually know if this is a bug in the rpm dev tools or
simply a release notes problem, but since a file I needed was missing
from the kernel-devel package, I tried to follow the release notes
instructions for building the full kernel source tree, and this
is what I got:

[root@zooty ~]# yumdownloader -e development-source --source kernel
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 26, in ?
    from yum.logger import Logger
ImportError: No module named logger

First roadblock - yumdownloader don't work, so I browse over to the SRPMS
tree in firefox and download the rpm that way, then I try to prepare
the tree, and I get this:

[root@zooty SPECS]# rpmbuild -bp --target $(uname -m) kernel-2.6.spec
Building target platforms: x86_64
Building for target x86_64
error: Failed build dependencies:
        unifdef is needed by kernel-2.6.17-1.2647.x86_64

Don't know what unifdef is a part of, but it apparently isn't part of
the rpmdevtools package the release notes say I need to install.

Version-Release number of selected component (if applicable):

kernel-2.6.17-1.2647.x86_64

How reproducible:

Don't thing the above errors are likely to change :-).

Steps to Reproduce:
1. see above
  
Actual results:

Can't prep kernel source tree

Expected results:

Nice expanded source tree under BUILD directory

Additional info:

Missing file described in bug 206827.
Comment 1 Tom Horsley 2006-09-17 15:22:23 EDT
OK, I found unifdef in extras, and was finally able to get the kernel
source prepped. I guess the only actual bug here is the problem with
yumdownloader, but the release notes on kernel development probably
ought to mention unifdef as another rpm that needs installing
(along with rpmdevtools and yum-utils).
Comment 2 Paul Nasrat 2006-09-18 05:28:54 EDT
yumdownloader fixed on upstream mailing list - needs new release see bug 
# 199175

*** This bug has been marked as a duplicate of 199175 ***

Note You need to log in before you can comment on or make changes to this bug.