Bug 206898 - Unable to switch to text console by CTRL-ALT-F1
Unable to switch to text console by CTRL-ALT-F1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-keyboard (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
: Regression
: 212530 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-17 19:28 EDT by Jan Kratochvil
Modified: 2008-07-21 19:58 EDT (History)
11 users (show)

See Also:
Fixed In Version: 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 19:58:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm --qf "%{name}-%{version}-%{release}.%{arch}\n" -qa|sort| (32.36 KB, text/plain)
2006-10-17 04:31 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2006-09-17 19:28:32 EDT
Description of problem:
Formerly I could switch to the text consoles by CTRL-ALT-F1, CTRL-ALT-F2 etc.

Version-Release number of selected component (if applicable):
xorg-x11-apps-7.1-2.fc6
xorg-x11-drivers-7.1-3
xorg-x11-drv-acecad-1.1.0-2.1
xorg-x11-drv-aiptek-1.0.1-2
xorg-x11-drv-apm-1.1.1-2.1
xorg-x11-drv-ark-0.6.0-2.1
xorg-x11-drv-ast-0.81.0-3
xorg-x11-drv-ati-6.6.2-1.fc6
xorg-x11-drv-calcomp-1.1.0-1.1
xorg-x11-drv-chips-1.1.1-2.1
xorg-x11-drv-cirrus-1.1.0-2.fc6
xorg-x11-drv-citron-2.2.0-1.1
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-digitaledge-1.1.0-1.1
xorg-x11-drv-dmc-1.1.0-2
xorg-x11-drv-dummy-0.2.0-2.1
xorg-x11-drv-dynapro-1.1.0-2
xorg-x11-drv-elo2300-1.1.0-1.1
xorg-x11-drv-elographics-1.1.0-1.1
xorg-x11-drv-evdev-1.1.2-2.1
xorg-x11-drv-fbdev-0.3.0-2
xorg-x11-drv-fpit-1.1.0-1.1
xorg-x11-drv-glint-1.1.1-4.1
xorg-x11-drv-hyperpen-1.1.0-2
xorg-x11-drv-i128-1.2.0-4
xorg-x11-drv-i740-1.1.0-2.1
xorg-x11-drv-i810-1.6.5-6.fc6
xorg-x11-drv-jamstudio-1.1.0-1.1
xorg-x11-drv-joystick-1.1.0-1.1
xorg-x11-drv-keyboard-1.1.0-2.1
xorg-x11-drv-magellan-1.1.0-1.1
xorg-x11-drv-magictouch-1.0.0.5-2.1
xorg-x11-drv-mga-1.4.1-5.fc6
xorg-x11-drv-microtouch-1.1.0-1.1
xorg-x11-drv-mouse-1.1.1-1.1
xorg-x11-drv-mutouch-1.1.0-2
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-nsc-2.8.1-2.1
xorg-x11-drv-nv-1.2.0-4.fc6
xorg-x11-drv-palmax-1.1.0-1.1
xorg-x11-drv-penmount-1.1.0-2.1
xorg-x11-drv-rendition-4.1.0-3.1
xorg-x11-drv-s3-0.4.1-2.1
xorg-x11-drv-s3virge-1.9.1-2.1
xorg-x11-drv-savage-2.1.1-5.fc6
xorg-x11-drv-siliconmotion-1.4.1-2.1
xorg-x11-drv-sis-0.9.1-5
xorg-x11-drv-sisusb-0.8.1-4.1
xorg-x11-drv-spaceorb-1.1.0-1.1
xorg-x11-drv-summa-1.1.0-1.1
xorg-x11-drv-tdfx-1.2.1-3.1
xorg-x11-drv-trident-1.2.1-3.fc6
xorg-x11-drv-tseng-1.1.0-3.1
xorg-x11-drv-ur98-1.1.0-1.1
xorg-x11-drv-v4l-0.1.1-4
xorg-x11-drv-vesa-1.2.1-2
xorg-x11-drv-vga-4.1.0-2.1
xorg-x11-drv-via-0.2.1-4.1
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-vmware-10.13.0-2.1
xorg-x11-drv-void-1.1.0-3.1
xorg-x11-drv-voodoo-1.1.0-3.1
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-font-utils-7.1-2
xorg-x11-fonts-Type1-7.1-2
xorg-x11-fonts-base-7.1-2
xorg-x11-fonts-misc-7.1-2
xorg-x11-proto-devel-7.1-7.fc6
xorg-x11-resutils-7.1-2.fc6
xorg-x11-server-Xorg-1.1.1-38.fc6
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-util-macros-1.0.2-4.fc6
xorg-x11-utils-7.1-2.fc6
xorg-x11-xauth-1.0.1-2.1
xorg-x11-xdm-1.0.5-5.fc6
xorg-x11-xfs-1.0.2-3.1
xorg-x11-xfwp-1.0.1-3.1
xorg-x11-xinit-1.0.2-9.fc6
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-xsm-1.0.2-4.fc6
kernel-2.6.17-1.2647.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Install RawHide system with Gnome.
2. On the initial GDM Login Screen CTRL-ALT-F1 still works.
3. Login and start your Gnome session.
  
Actual results:
CTRL-ALT-F1 no longer works, it writes regular "P" character instead.

Expected results:
CTRL-ALT-F1 should switch to the text console.

Additional info:
Tried to change different "Keyboard Model"s in "Keyboard Preferences".
Tried to use 'Option  "XkbDisable"' in "xorg.conf".
Comment 1 Jan Kratochvil 2006-10-12 11:00:28 EDT
I found out it is more serious than expected.
In the cases where application (OpenOffice.org this time) will grab your input
(like if using popup menus) and stops responding - you no longer can switch to
the text console and free your mouse/keyboard by kill(1)ing of that app.
Mouse still moves on the X screen but the clicks have no longer any effect.
(These cases are not reproducible for me, otherwise they would get bugreported.)
Comment 2 Matthias Clasen 2006-10-17 01:16:01 EDT
do you have xkeyboard-config installed ?
Comment 3 Jan Kratochvil 2006-10-17 04:31:06 EDT
Created attachment 138667 [details]
rpm --qf "%{name}-%{version}-%{release}.%{arch}\n" -qa|sort|

Yes: xkeyboard-config-0.8-7.fc6.noarch
Full "rpm -qa" attached.
Comment 4 Petr Michalek 2006-10-29 17:31:29 EST
I have got same problem with FC6.
Comment 5 Jan Kratochvil 2006-10-29 17:44:00 EST
`chvt 1' works as a workaround but usually one cannot enter it with a grabbed
keyboard input.
Comment 6 Greg Huber 2006-10-30 20:10:57 EST
I appear to have the same problem with FC6. When I hit CTRL-ALT-F(1..6) the
screen goes blank and the system appears to hang as I can neither shut
down with a short power button, nor can I access it remotely. CTRL-ALT-F7
does not bring it back either.
Comment 7 Miroslav Pragl 2006-11-03 06:55:47 EST
Same prob here with FC6. I have also found problem with keyboard indicator
crashing just after logon
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=213163) - could these bugs
be related?
Comment 8 Dan Horák 2006-11-27 11:25:15 EST
This issue is rather complicated. Now I am on FC6/x86_64. There are situations
where switching works (a bit) and other where it doesn't work.
It works when
  - only one keyboard is defined in both System/Preferences/Keyboard=S/P/K and
System/Administration/Keyboard=S/A/K
  - I have two keyboards in S/P/K (US and Czech) and I switch it in S/A/K
(between US and US international), but only during the session
  - on my notebook S/A/K is US (propagated into xorg.conf) and in S/P/K I have
US international and Czech qwerty

Another issue is what happens when Gnome asks "use X or Gnome settings for
keyboard".

It should be possible to define some patterns from this behaviour, but will
require a lot of time (at least).
Comment 9 Matěj Cepl 2006-12-27 11:53:04 EST
*** Bug 212530 has been marked as a duplicate of this bug. ***
Comment 10 Pavel Starek 2007-07-02 16:16:12 EDT
However same thing comes with Fedora 7.
Comment 11 Tomas Mraz 2007-08-24 06:04:38 EDT
Could this be a problem with the czech xkb layouts? Note mostly .cz people are
cced here.
Comment 12 Miroslav Pragl 2007-08-24 06:07:37 EDT
I use FC7 and as I use only MOUSE to switch keyboard layouts I don't have such 
a problem

MP
Comment 13 Jan Kratochvil 2007-08-24 06:14:18 EDT
Workaround from tmraz:
Alt/Win key behavior->Meta is mapped to the Win-keys.
(besides that also using:
Group Shift/Lock behavior->Right Win-key switches group while pressed.
Use keyboard LED to show alternative group->ScrollLock LED shows blahblah.
)
Primary keyboard: U.S. English
Secondary keyboard: Czechia qwerty

Still the switching is possible only by right-ctrl/alt-F1 (not left-ctrl/alt-F1).
Comment 14 Dan Horák 2007-12-02 12:52:48 EST
In Fedora 8 everything works as expected, no workarounds needed (AFAICT).
Comment 15 MASAO TAKAHASHI 2007-12-03 00:54:46 EST
With linux-2.6.23.9-67.fc8, I have a same problem.
But with linux-2.6.21-1.3194.fc7, I have not a same problem.
And with linux-2.6.24-0.63.rc3-git6.fc9, a same problem is remained.
My keyboard is japanese 106.
Comment 16 Bug Zapper 2008-05-13 22:21:59 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Peter Hutterer 2008-07-18 00:23:32 EDT
What's the status of this bug?

upstream Xorg had a number of vt switching and many of them are resolved now in
server 1.5 (F9). Switching between us, de and cz layout works fine here,
including VT switches.
Comment 18 Dan Horák 2008-07-18 03:04:13 EDT
The problems with the czech keyboards are solved since F8, so the japanese
keyboard can be the remaining problem (comment #15), setting NEEDINFO.
Comment 19 Matěj Cepl 2008-07-18 06:46:35 EDT
Masao, can you switch between console and logged-in Gnome session with upgraded
F9, please?
Comment 20 MASAO TAKAHASHI 2008-07-21 19:09:29 EDT
(In reply to comment #19)
> Masao, can you switch between console and logged-in Gnome session with upgraded
> F9, please?
Yes, I can .

Comment 21 Peter Hutterer 2008-07-21 19:58:25 EDT
Calling it fixed then.

Note You need to log in before you can comment on or make changes to this bug.