Bug 20693 - RFE: install sample .rc files to /usr/share/mutt
Summary: RFE: install sample .rc files to /usr/share/mutt
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mutt   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-12 02:24 UTC by Daniel Roesen
Modified: 2014-03-17 02:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-12 02:24:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Roesen 2000-11-12 02:24:06 UTC
Recently I switched to using RH's mutt RPMs (but adding compressed folders
patch) and stumbled over the following problem:

In my standard .muttrc (which I use on many machines), I had:

source /usr/local/doc/mutt/samples/gpg.rc

Now I have to use:

source /usr/doc/mutt-1.2.5i/gpg.rc

The latter is not version independant so when upgrading mutt I will have to
change this path in all my .muttrc files. It would be better to have at
least the PGP/GnuPG interface .rc files in a version-independent location
such as /usr/share/mutt.

Comment 1 Daniel Roesen 2000-12-02 00:51:42 UTC
I overlooked the following .spec part:

cat contrib/gpg.rc >> \
    $RPM_BUILD_ROOT/etc/Muttrc

so it's not needed at all to include gpg.rc at all in the user's .muttrc,
although it's probably a good idea to have the other PGP .rc interfaces
somewhere in /usr/share/mutt

Marking NOTABUG (because there is nothing like "INVALID" as resolution)


Note You need to log in before you can comment on or make changes to this bug.